<!doctype html>
<html lang="en" style="display: block;min-width:1070px;">
<head>
<meta name="distribution" content="global" />
<meta name="robots" content="follow, all" />
 <meta content="text/html; charset=UTF-8" http-equiv="Content-Type" />
<meta name="google-site-verification" content="rcmqt74A6mEeS1xWVk3k3EMZbTi79AN2WJOyWXg0dJ4" />
<meta name="msvalidate.01" content="8D3F505D642C99EB26E45507554512BC" />
<meta name="norton-safeweb-site-verification" content="h3g5-5vc1eyl4ciu70dj759ufgj5zl-7d5xcemulxrycwbv3wlj320gvmjpuq6b5jmxx5rr7cxxk7csxy3xj4agugrktrdyd9qm3j-bhsojxzag5053lgfxnptkgp8o7" />
<meta name="viewport" content="width=1070">
<meta property="fb:pages" content="235821283247357" />



<!-- Escape from Frames -->
<script type="text/javascript">if(self==top){document.documentElement.style.display="block"}else{top.location=self.location}</script>
<link rel="stylesheet" href="https://www.wkrb13.com/wp-content/themes/newsalambre/style.css?v=10" type="text/css" media="screen" />
<link href="https://www.wkrb13.com/feed" rel="alternate" title="WKRB News RSS Feed" type="application/rss+xml" />
<link href="https://www.wkrb13.com/feed/atom" rel="alternate" title="WKRB News Atom Feed" type="application/atom+xml" />
<link href="https://www.wkrb13.com/xmlrpc.php" rel="pingback" />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://www.wkrb13.com/wp-includes/css/dist/block-library/style.min.css?ver=5.3.4' type='text/css' media='all' />
<link rel='https://api.w.org/' href='https://www.wkrb13.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.wkrb13.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.wkrb13.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Brokerages Set Haymaker Acquisition Corp. (NYSE:OSW) PT at $12.80' href='https://www.wkrb13.com/2020/07/05/brokerages-set-haymaker-acquisition-corp-nyseosw-pt-at-12-80.html' />
<link rel='next' title='$518.93 Million in Sales Expected for IDEX Co. (NYSE:IEX) This Quarter' href='https://www.wkrb13.com/2020/07/05/518-93-million-in-sales-expected-for-idex-co-nyseiex-this-quarter.html' />
<meta name="generator" content="WordPress 5.3.4" />
<link rel="canonical" href="https://www.wkrb13.com/2020/07/05/brokerages-set-bloomin-brands-inc-nasdaqblmn-price-target-at-14-42.html" />
<link rel='shortlink' href='https://www.wkrb13.com/?p=1947984' />
<link rel="alternate" type="application/json+oembed" href="https://www.wkrb13.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.wkrb13.com%2F2020%2F07%2F05%2Fbrokerages-set-bloomin-brands-inc-nasdaqblmn-price-target-at-14-42.html" />
<link rel="alternate" type="text/xml+oembed" href="https://www.wkrb13.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.wkrb13.com%2F2020%2F07%2F05%2Fbrokerages-set-bloomin-brands-inc-nasdaqblmn-price-target-at-14-42.html&#038;format=xml" />
<link rel="amphtml" href="https://www.wkrb13.com/2020/07/05/brokerages-set-bloomin-brands-inc-nasdaqblmn-price-target-at-14-42.html/amp" /><link rel="icon" href="https://www.wkrb13.com/wp-content/uploads/2018/03/wkrb13-03-150x150.png" sizes="32x32" />
<link rel="icon" href="https://www.wkrb13.com/wp-content/uploads/2018/03/wkrb13-03.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://www.wkrb13.com/wp-content/uploads/2018/03/wkrb13-03.png" />
<meta name="msapplication-TileImage" content="https://www.wkrb13.com/wp-content/uploads/2018/03/wkrb13-03.png" />

<!-- Start Meta Data -->
<title>Brokerages Set Bloomin&#8217; Brands Inc (NASDAQ:BLMN) Price Target at $14.42 - WKRB News</title>
<meta name="description" content="Bloomin&#8217; Brands Inc (NASDAQ:BLMN) has earned an average recommendation of &#8220;Hold&#8221; from the seventeen ratings firms that are presently covering the firm, MarketBeat reports. One research analyst has rated the stock with a sell recommendation, seven have given a hold recommendation and eight have issued a buy recommendation on the company. The average 1 year [&hellip;]" />
<meta name="author" content="Jim Brewer">
<meta name="news_keywords" content="Bloomin' Brands,NASDAQ:BLMN,BLMN,Retail/Wholesale,09423510,Ratings,Consensus" />
<meta name="keywords" content="Bloomin' Brands,NASDAQ:BLMN,BLMN,Retail/Wholesale,09423510,Ratings,Consensus" />
<meta name="ticker" content="NASDAQ:BLMN" />
<meta name="contentType" content="article">

<!-- Twitter Card Data -->
<meta name="twitter:card" content="summary"/>
<meta name="twitter:site" content="@RatingsNetwork" />
<meta name="twitter:title" content="Brokerages Set Bloomin&#8217; Brands Inc (NASDAQ:BLMN) Price Target at $14.42"/>
<meta name="twitter:description" content="Bloomin&#8217; Brands Inc (NASDAQ:BLMN) has earned an average recommendation of &#8220;Hold&#8221; from the seventeen ratings firms that are presently covering the firm, MarketBeat reports. One research analyst has rated the stock with a sell recommendation, seven have given a hold recommendation and eight have issued a buy recommendation on the company. The average 1 year [&hellip;]" />
<meta name="twitter:creator" content="@RatingsNetwork" />
<meta name="twitter:image" content="https://www.marketbeat.com/logos/bloomin-brands-inc-logo.jpg" />

<!-- Open Graph Data -->
<meta property="og:title" content="Brokerages Set Bloomin&#8217; Brands Inc (NASDAQ:BLMN) Price Target at $14.42" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.wkrb13.com/2020/07/05/brokerages-set-bloomin-brands-inc-nasdaqblmn-price-target-at-14-42.html" />
<meta property="og:image" content="https://www.marketbeat.com/logos/bloomin-brands-inc-logo.jpg" />
<meta property="og:description" content="Bloomin&#8217; Brands Inc (NASDAQ:BLMN) has earned an average recommendation of &#8220;Hold&#8221; from the seventeen ratings firms that are presently covering the firm, MarketBeat reports. One research analyst has rated the stock with a sell recommendation, seven have given a hold recommendation and eight have issued a buy recommendation on the company. The average 1 year [&hellip;]" />
<meta property="og:site_name" content="WKRB News" />
<meta property="og:locale" content="en_US" />

<!-- OG Article Template -->
<meta property="article:published_time" content="2020-07-05T04:42:41+0000" />
<meta property="article:modified_time" content="2020-07-05T04:42:41+0000" />
<meta property="article:tag" content="NASDAQ:BLMN" />
<meta property="article:tag" content="Bloomin' Brands,NASDAQ:BLMN,BLMN,Retail/Wholesale,09423510,Ratings,Consensus" />
<meta property="article:section" content="Markets" />

<!-- Google meta is in the body-->

<!-- End Meta Data -->

	
<script type='text/javascript'>var PopupAdChannel=''; </script>

  <link rel="manifest" href="/manifest.json">
  <script src="https://cdn.onesignal.com/sdks/OneSignalSDK.js"></script>
  <script>
  	function registerUserChange(action) {
		OneSignal.getUserId( function(userId) {
			OneSignalIdString = userId;
			var Domain = 'wkrb13.com';
			var url = "https://www.marketbeat.com/scripts/OneSignalTracking.ashx?OneSignalID=" + OneSignalIdString + "&domain=" + Domain + "&action=" + action;
			var xhr = new XMLHttpRequest();
			xhr.open('GET', url);
			xhr.onload = function () {
				if (xhr.status !== 200) {
					console.log('GET failed.  Returned status of ' + xhr.status);
				}
			};
			xhr.send();
		});
	}
    var OneSignal = window.OneSignal || [];
    OneSignal.push(["init", {
      appId: "27539f7d-08b9-4089-9eac-48d0d5b908a5",
      safari_web_id: 'web.onesignal.auto.54cd441e-7f12-4aed-9845-f98eb5c10ecb', 
      autoRegister: false,
      notifyButton: {
        enable: false /* Set to false to hide */
      },
 welcomeNotification: {
        "title": "Join Wall Street's Brightest Minds.",
        "message": "Receive research in your inbox from top analysts, before the market opens. Click here to learn how.",
         "url": "https://www.marketbeat.com/subscribe/subscribe.aspx?ReferralType=OneSignalThankYou&ProductCode=1997t"
    }
    },
		OneSignal.once('subscriptionChange', function (isSubscribed) {
			if(isSubscribed) {
				registerUserChange("subscribe");
			}
			else {
				registerUserChange("unsubscribe");
			}
			
		  })
	]);
	if((navigator.userAgent.toLowerCase().indexOf('firefox') > -1)||((navigator.userAgent.toLowerCase().indexOf('safari') > -1)&&(!(navigator.userAgent.toLowerCase().indexOf('chrome') > -1)))){
		OneSignal.showSlidedownPrompt();
	} else {
		OneSignal.showNativePrompt();		
	}	  
  </script>
	
<script type="text/javascript">var vbnfgha = '211626'; var ertdfga = '13739-bup-ac'; var qhyuioa = '53938'; var AdClientID = qhyuioa + vbnfgha + ertdfga; AdClientID = AdClientID.split("").reverse().join("");</script>

<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({
          google_ad_client: AdClientID,
          enable_page_level_ads: true
     });
</script>
<!-- Start IMS -->
<script type="text/javascript">
		var apntag = apntag || {};
		apntag.anq = apntag.anq || [];
		(function() {
			var d = document, e = d.createElement('script'), p = d.getElementsByTagName('head')[0];
			e.type = 'text/javascript';  e.async = true;
			e.src = '//acdn.adnxs.com/ast/ast.js';
			p.insertBefore(e, p.firstChild);
		})();

		
		apntag.anq.push(function() {
			apntag.setPageOpts({
				member: 6989
			});
		});

		apntag.anq.push(function() {

      		apntag.defineTag({
				tagId: 13481205,
				sizes: [[300,250],[300,600],[300,1050]],
				keywords: {'position': ['RightRail_1']},
				targetId: 'WKRBFinancialNews_ROS_RightRail_1'
			});
					});

		apntag.anq.push(function() {
			apntag.loadTags();
		});
		</script>
	
<script type="text/javascript">
(function() {
window.advBidxc = window.advBidxc || {};
window.advBidxc.startTime = new Date().getTime();
function loadScript(tagSrc) {
var scriptTag = document.createElement('script'),
placeTag = document.getElementsByTagName("script")[0];
scriptTag.type = 'text/javascript';
scriptTag.async = true;
scriptTag.src = tagSrc;
placeTag.parentNode.insertBefore(scriptTag, placeTag);
}
var mnSrc = '//hbx.media.net/bidexchange.js?cid=8CU2C156D&version=5.1' + '&dn=' +
window.location.hostname;
loadScript(mnSrc);
})();
</script>
<!-- End IMS --> 

	<script type="text/javascript" src="https://www.marketbeat.com/Scripts/lowerrightad.js?v=9"></script>

</head>
<body>
<div id="wrap">

<!-- Start MarketBeat Modern Popup -->
<link rel="stylesheet" type="text/css" media="all" href="https://www.marketbeat.com/scripts/modal/modernpopup.css?v=11"/>
<script type="text/javascript" src="https://www.marketbeat.com/scripts/modal/modernpopup.js?v=52"></script>

	<script type="text/javascript">LoadPopupRatings('ModernMarketsPopup-WKRB News', 'wkrb13.com', 'NASDAQ:BLMN', 'Bloomin\' Brands', 'https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?w=175&zc=1&src=https://www.marketbeat.com/logos/bloomin-brands-inc-logo.jpg');</script>
<!-- End MarketBeat Modern Popup -->
	
<header>
	<div id="top-bar">
		<div class="width-limiter">
				<!-- top nav bar -->
				<nav class="navigation"><ul id="menu-top-bar" class="menu"><li id="menu-item-19" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-19"><a href="https://wkrb13.com">Home</a></li>
<li id="menu-item-18" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-18"><a href="https://www.wkrb13.com/about">About</a></li>
<li id="menu-item-17" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-17"><a href="https://www.wkrb13.com/daily-email-updates-basic">Daily Email Updates</a></li>
<li id="menu-item-47" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-47"><a href="https://www.wkrb13.com/privacy-policy">Privacy Policy</a></li>
</ul></nav>				<form id="searchform" action="https://www.wkrb13.com/" method="get">
					<div id="search">
						<input id="s" class="searchinput" name="s" onclick="this.value='';" type="text" />
						<input class="searchsubmit" type="submit" value="Search" />
					</div>
				</form><!-- end: searchform -->
		</div><!-- end: width-limiter in top-bar -->
	</div><!-- end: top-bar -->
	<div class="width-limiter add-padding"><!-- start: width-limiter with logo and space for alternate header unit -->
		<a class="logo-link" href="https://www.wkrb13.com"><img id="logo" src="/wp-content/uploads/2018/03/wkrb13-01-2.png" alt="WKRB News and Analysis logo"></a>

<!-- Begin Header Unit -->
<div id="AlternateHeaderUnit">
		
		<iframe src="https://marketbeat.com/scripts/HeaderAdNewsSites.ashx" width="728" height="90" frameborder="no" scrolling="no"></iframe>
			</div> 

<!-- End Header Unit-->
	</div> <!-- end: width-limiter with logo and space for alternate header unit -->
	<div id="menu">
		<div class="width-limiter" id="nav-main">
			<!-- start main category menu -->
			<nav class="navigation"><ul id="menu-category-menu" class="menu"><li id="menu-item-31" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-31"><a href="https://www.wkrb13.com/category/markets">Markets</a></li>
<li id="menu-item-60" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-60"><a href="https://www.wkrb13.com/category/markets/analyst-articles-us">Ratings</a></li>
<li id="menu-item-54" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-54"><a href="https://www.wkrb13.com/category/markets/dividend-articles">Dividends</a></li>
<li id="menu-item-55" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-55"><a href="https://www.wkrb13.com/category/markets/earnings-articles-single">Earnings</a></li>
<li id="menu-item-56" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56"><a href="https://www.wkrb13.com/category/markets/insider-trades">Insider Trades</a></li>
<li id="menu-item-24" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24"><a href="https://www.wkrb13.com/category/markets/cryptocurrencies">Cryptocurrencies</a></li>
</ul></nav>		</div> <!-- end: width-limiter for menu -->
	</div> <!-- end: menu -->
</header> <!-- end: header -->
	<div class="width-limiter main-content">
		
<aside>
	
<iframe src="https://marketbeat.com/scripts/MoreOnMarketBeat.aspx" width="336" height="600" frameborder="no"></iframe><br><br>	
	
<div class="ad336x280" style='width:336px;height:280px'>
<!-- Network Wide AdSense Unit - Top Sidebar Position -->
<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-9373162611283935" data-ad-slot="1875628183" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>(adsbygoogle = window.adsbygoogle || []).push({});</script>
<!-- End AdSense Unit -->
	</div>
<!-- end first square unit -->

<div class="ad336x280" style='width:336px;height:280px'>
<!-- Network Wide AdSense Unit - Middle Sidebar Position -->
<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-9373162611283935" data-ad-slot="9445683366" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>(adsbygoogle = window.adsbygoogle || []).push({});</script>
<!-- End AdSense Unit -->
	</div>
	
<!-- end second square unit -->


<!-- OptIn Form -->

<!-- Start Sidebar Registration -->
    <div class="sidebar-email">
                        <h3>Daily Ratings &amp; News for Bloomin' Brands</h3>
        	Complete the form below to receive the latest headlines and analysts' recommendations for Bloomin' Brands with our free daily email newsletter:<br/>
        <form method="get" action="https://www.marketbeat.com/newsletter/default.aspx">
        <input id="RegisterEmailSidebar" name="RegisterEmail" type="email" placeholder="Your Email Address">
        <input type="hidden" id="Hidden1" name="RegistrationCode" value="WKRB News-Sidebar">
        <input type="hidden" id="Hidden2" name="RegisterTicker" value="NASDAQ:BLMN" />        <input type="submit" name="submit" onclick="return CheckEmail('RegisterEmailSidebar', 'ShowSuggestionSidebar');" value="Subscribe Now (Free Sign-Up)" class="button" style="width:336px;height:30px">
    <div id="ShowSuggestionSidebar" style="padding-top:7px"></div>
    </form>
    </div>

<!-- End Sidebar Registration -->


<div>
<a class="twitter-follow-button"
  href="https://twitter.com/wkrbnews"
  data-size="large">
Follow @WKRBNews</a>
<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script>
<br>
<br>

<iframe src="https://www.facebook.com/plugins/like.php?href=https%3A%2F%2Fwww.facebook.com%2Fwkrbnews%2F&width=336&layout=standard&action=like&size=small&show_faces=true&share=true&height=80&appId" width="336" height="80" style="border:none;overflow:hidden" scrolling="no" frameborder="0" allowTransparency="true"></iframe>

</div>

<!-- Start IMS -->
<div id="WKRBFinancialNews_ROS_RightRail_1" class="text-center">
			<script type="text/javascript">
			apntag.anq.push(function() {
				apntag.showTag('WKRBFinancialNews_ROS_RightRail_1');
			});
			</script>
		</div>
<!-- End IMS --> 


<!-- start Recent Posts -->
        <br/>
        <div>
        <h3>Recent Posts</h3>
            <ul>
                        <li class="recent-posts"><a href="https://www.wkrb13.com/2020/07/05/beaxy-achieves-market-cap-of-2-16-million-bxy.html">Beaxy Achieves Market Cap of $2.16 Million (BXY)</a></li>
                        <li class="recent-posts"><a href="https://www.wkrb13.com/2020/07/05/boutspro-achieves-market-cap-of-149074-76-bouts.html">BoutsPro Achieves Market Cap of $149,074.76 (BOUTS)</a></li>
                        <li class="recent-posts"><a href="https://www.wkrb13.com/2020/07/05/ebcoin-ebc-trading-up-10-4-over-last-7-days.html">EBCoin (EBC) Trading Up 10.4% Over Last 7 Days</a></li>
                        <li class="recent-posts"><a href="https://www.wkrb13.com/2020/07/05/vndc-reaches-market-cap-of-4-35-million-vndc.html">VNDC Reaches Market Cap of $4.35 Million (VNDC)</a></li>
                        <li class="recent-posts"><a href="https://www.wkrb13.com/2020/07/05/newscrypto-nwc-market-cap-reaches-2-88-million.html">Newscrypto (NWC) Market Cap Reaches $2.88 Million</a></li>
                        <li class="recent-posts"><a href="https://www.wkrb13.com/2020/07/05/qitmeer-hlc-reaches-24-hour-trading-volume-of-46838-00.html">Qitmeer (HLC) Reaches 24-Hour Trading Volume of $46,838.00</a></li>
                        <li class="recent-posts"><a href="https://www.wkrb13.com/2020/07/05/ouroboros-hits-market-capitalization-of-297319-11-ouro.html">Ouroboros Hits Market Capitalization of $297,319.11 (OURO)</a></li>
                        <li class="recent-posts"><a href="https://www.wkrb13.com/2020/07/05/insights-network-instar-trading-18-3-higher-over-last-week.html">Insights Network (INSTAR) Trading 18.3% Higher  Over Last Week</a></li>
                        <li class="recent-posts"><a href="https://www.wkrb13.com/2020/07/05/jetcoin-one-day-trading-volume-reaches-404397-00-jet.html">Jetcoin One Day Trading Volume Reaches $404,397.00 (JET)</a></li>
                        <li class="recent-posts"><a href="https://www.wkrb13.com/2020/07/05/cova-cova-trading-down-19-7-over-last-7-days.html">COVA (COVA) Trading Down 19.7% Over Last 7 Days</a></li>
                        <li class="recent-posts"><a href="https://www.wkrb13.com/2020/07/05/pyrk-trading-18-8-lower-over-last-7-days-pyrk.html">Pyrk  Trading 18.8% Lower  Over Last 7 Days (PYRK)</a></li>
                        <li class="recent-posts"><a href="https://www.wkrb13.com/2020/07/05/remme-rem-price-up-8-2-this-week.html">Remme (REM) Price Up 8.2% This Week</a></li>
                        <li class="recent-posts"><a href="https://www.wkrb13.com/2020/07/05/decentralized-asset-trading-platform-trading-up-7-over-last-7-days-datp.html">Decentralized Asset Trading Platform Trading Up 7% Over Last 7 Days (DATP)</a></li>
                        <li class="recent-posts"><a href="https://www.wkrb13.com/2020/07/05/blackmoon-trading-down-6-2-this-week-bmc.html">Blackmoon Trading Down 6.2% This Week (BMC)</a></li>
                        <li class="recent-posts"><a href="https://www.wkrb13.com/2020/07/05/450-91-million-in-sales-expected-for-harsco-co-nysehsc-this-quarter.html">$450.91 Million in Sales Expected for Harsco Co. (NYSE:HSC) This Quarter</a></li>
                        <li class="recent-posts"><a href="https://www.wkrb13.com/2020/07/05/zacks-analysts-anticipate-ingersoll-rand-plc-nyseir-will-announce-earnings-of-0-19-per-share.html">Zacks: Analysts Anticipate Ingersoll-Rand PLC (NYSE:IR) Will Announce Earnings of $0.19 Per Share</a></li>
                        <li class="recent-posts"><a href="https://www.wkrb13.com/2020/07/05/518-93-million-in-sales-expected-for-idex-co-nyseiex-this-quarter.html">$518.93 Million in Sales Expected for IDEX Co. (NYSE:IEX) This Quarter</a></li>
                        <li class="recent-posts"><a href="https://www.wkrb13.com/2020/07/05/brokerages-set-bloomin-brands-inc-nasdaqblmn-price-target-at-14-42.html">Brokerages Set Bloomin&#8217; Brands Inc (NASDAQ:BLMN) Price Target at $14.42</a></li>
                        <li class="recent-posts"><a href="https://www.wkrb13.com/2020/07/05/318-08-million-in-sales-expected-for-helmerich-payne-inc-nysehp-this-quarter.html">$318.08 Million in Sales Expected for Helmerich &#038; Payne, Inc. (NYSE:HP) This Quarter</a></li>
                        <li class="recent-posts"><a href="https://www.wkrb13.com/2020/07/05/brokerages-expect-h-r-block-inc-nysehrb-will-post-earnings-of-0-32-per-share.html">Brokerages Expect H &#038; R Block Inc (NYSE:HRB) Will Post Earnings of $0.32 Per Share</a></li>
                        </ul>
        </div>  

<!-- end recent posts -->
</aside><!--end #sidebar-->
		<main>
			 <article itemscope itemtype="http://schema.org/NewsArticle">
				
				<link itemprop="mainEntityOfPage" href="https://www.wkrb13.com/2020/07/05/brokerages-set-bloomin-brands-inc-nasdaqblmn-price-target-at-14-42.html" />
				<h1 itemprop="headline" class="page-title">Brokerages Set Bloomin&#8217; Brands Inc (NASDAQ:BLMN) Price Target at $14.42</h1>
				
				<p class="postmeta">
					Posted by <span itemprop="author" itemscope itemtype="https://schema.org/Person"><span itemprop="name"><a href="https://www.wkrb13.com/author/jimb" title="Posts by Jim Brewer" rel="author">Jim Brewer</a></span></span> on <span itemprop="datePublished dateModified" content="2020-07-05T04:42:41+0000">Jul 5th, 2020</span>
				</p><!--end .postmeta-->
				<!--sse-->
				<div class="entry" itemprop="articleBody"> 
				<!-- start main text -->
					
					<p><img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?w=250&zc=1&src=https://www.marketbeat.com/logos/bloomin-brands-inc-logo.jpg" alt="Bloomin' Brands logo" title="Bloomin' Brands logo" class="companylogo" />Bloomin&#8217; Brands Inc (NASDAQ:BLMN) has earned an average recommendation of &#8220;Hold&#8221; from the seventeen ratings firms that are presently  covering the firm, <a href='https://www.marketbeat.com/'>MarketBeat</a> reports. One research analyst  has rated the stock with a sell recommendation, seven have given a hold recommendation and eight have issued  a buy recommendation on  the company. The average 1 year price objective among analysts that have issued a report on the stock in the last year is $14.23. </p>
<p>Several equities analysts have recently commented on the company. <a style='font-weight:bold' href='http://www.americanconsumernews.net/scripts/click.aspx?Zacks=1'>Zacks Investment Research</a> cut Bloomin&#8217; Brands from a &#8220;buy&#8221; rating to a &#8220;hold&#8221; rating in a research note on Wednesday, April 15th. Gordon Haskett cut Bloomin&#8217; Brands from a &#8220;buy&#8221; rating to a &#8220;hold&#8221; rating and reduced their price objective for the stock from $14.00 to $12.00 in a research note on Wednesday. Barclays cut their target price on Bloomin&#8217; Brands from $29.00 to $13.00 and set an &#8220;overweight&#8221; rating on the stock in a research note on Monday, May 11th. Wells Fargo &#038; Co raised their target price on Bloomin&#8217; Brands from $11.00 to $12.00 and gave the company an &#8220;equal weight&#8221; rating in a research note on Monday, May 11th. Finally, Loop Capital cut their target price on Bloomin&#8217; Brands from $27.00 to $15.00 and set a &#8220;buy&#8221; rating on the stock in a research note on Wednesday, May 13th.</p>					

<form method="get" action="https://www.marketbeat.com/newsletter/default.aspx" style="border-bottom-width: 1px; border-color: #D2D2D2; border-style: solid; border-top-width: 1px; margin-bottom: 24px; margin-top: 12px; padding: 12px 0;border-right:none;border-left:none;clear:both;">
    <input type="hidden" id="Hidden1" name="RegistrationCode" value="InPost-WKRB News"  />
    <input type="hidden" id="Hidden2" name="RegisterTicker" value="NASDAQ:BLMN" />    <label for="InPostRegistrationEmail">Get <b>Bloomin' Brands</b> alerts:</label>
    <div style="display:inline-block;"><input id="InPostRegistrationEmail" name="RegisterEmail" type="email" placeholder="Enter Your Email Address" style="border: 1px solid #D2D2D2;font-size: 12px;line-height: 18px;margin: 0;min-width: 200px; padding: 4px;" /><input type="submit" name="submit" onclick="return CheckEmail('InPostRegistrationEmail','ShowSuggestionInPost');" value="Submit" style="-webkit-appearance: none;-moz-appearance: none;appearance: none;background-color: #1361A2;border: 1px solid #1361A2;border-bottom-right-radius: .5em;border-top-right-radius: .5em;color: #fff;font-size: 12px;font-weight: 700;line-height: 18px;padding: 4px 18px"></input></div>
</form>
<div id="ShowSuggestionInPost"></div>


<p>Shares of <a href='https://www.marketbeat.com/stocks/NASDAQ/BLMN/price-target/' target='_blank' rel="noopener noreferrer">Bloomin&#8217; Brands stock</a> traded down $0.52 on Friday, hitting $10.18. The company&#8217;s stock had a trading volume of 4,076,381 shares, compared to its average volume of 4,404,062. The company has a market capitalization of $890.61 million, a P/E ratio of 32.84 and a beta of 1.77. The company has a quick ratio of 0.60, a current ratio of 0.68 and a debt-to-equity ratio of 26.67. The firm has a fifty day moving average price of $11.26 and a 200-day moving average price of $14.72. Bloomin&#8217; Brands has a 52-week low of $4.54 and a 52-week high of $24.29. </p>
<p>
		  <div style="float:left;padding-right: 10px;padding-bottom:10px;padding-top:10px;width:340px;">
<!-- Network Wide AdSense Unit - In-Post Position -->
<ins class="adsbygoogle" style="display:block; text-align:center;" data-ad-layout="in-article" data-ad-format="fluid" data-ad-client="ca-pub-9373162611283935" data-ad-slot="9254111670"></ins>
<script>(adsbygoogle = window.adsbygoogle || []).push({});</script>
<!-- End AdSense Unit -->
                 </div>


                 Bloomin&#8217; Brands (NASDAQ:BLMN) last announced its quarterly earnings data on Friday, May 8th. The restaurant operator reported $0.14 earnings per share for the quarter, hitting the Thomson Reuters&#8217; consensus estimate of $0.14. The business had revenue of $1.01 billion for the quarter, compared to analyst estimates of $575.35 million. Bloomin&#8217; Brands had a net margin of 0.79% and a return on equity of 57.88%. The company&#8217;s revenue was down 10.6% on a year-over-year basis. During the same period in the prior year, the firm posted $0.75 EPS.  As a group, analysts expect that  Bloomin&#8217; Brands will post -1.49 earnings per share for the current year. </p>
<p>In other news, COO Gregg Scarlett acquired 10,000 shares of the stock in a transaction dated Tuesday, May 12th. The shares were acquired at an average cost of $10.81 per share, for a total transaction of $108,100.00. Following the completion of the transaction, the chief operating officer now owns 70,929 shares in the company, valued at approximately $766,742.49. The transaction was disclosed in a filing with the Securities &amp; Exchange Commission, which is accessible through <a href="https://www.sec.gov/Archives/edgar/data/1546417/000154641720000065/xslF345X03/wf-form4_158949531184983.xml" target='_blank' rel="noopener noreferrer">this hyperlink</a>. Insiders own  4.39% of the company&#8217;s stock. </p>
<p>Hedge funds have recently made changes to their positions in the stock. Quantbot Technologies LP acquired a new position in  Bloomin&#8217; Brands in the fourth quarter worth $39,000.  Fieldpoint Private Securities LLC boosted its stake in  Bloomin&#8217; Brands by 75.4% in the fourth quarter. Fieldpoint Private Securities LLC now owns 2,458 shares of the restaurant operator&#8217;s stock worth $54,000 after purchasing an additional 1,057 shares in the last quarter.  Mercer Global Advisors Inc. ADV acquired a new position in  Bloomin&#8217; Brands in the first quarter worth $72,000.  Two Sigma Investments LP acquired a new position in  Bloomin&#8217; Brands in the first quarter worth $84,000.  Finally, Keebeck Alpha LP acquired a new position in  Bloomin&#8217; Brands in the first quarter worth $86,000. 88.60% of the stock is currently owned by institutional investors and hedge funds. </p>
<p><strong>About Bloomin&#8217; Brands</strong></p>
<p>Bloomin&#x27; Brands, Inc, through its subsidiaries, owns and operates casual, upscale casual, and fine dining restaurants in the United States and internationally. The company operates through two segments, U.S. and International. Its restaurant portfolio has four concepts, including Outback Steakhouse, a casual steakhouse restaurant; Carrabba&#x27;s Italian Grill, a casual Italian restaurant; Bonefish Grill, an upscale casual seafood restaurant; and Fleming&#x27;s Prime Steakhouse &amp; Wine Bar, a contemporary steakhouse.</p>
<p>See Also: <a href='https://www.marketbeat.com/financial-terms/how-to-trade-using-analysts-ratings/'>How to Trade Using Analysts Ratings</a><!--ViewCount:ArticleHistoryID=56534779&PostDate=2020-7-4&type=c&quarternary=1&id=875313--><!--Keyword: Bloomin' Brands,NASDAQ:BLMN,BLMN,Retail/Wholesale,09423510,Ratings,Consensus--><!--Ratings:4,13,NASDAQ:BLMN--></p>
<p style='text-align:center'><img src='https://www.marketbeat.com/scripts/RatingsChart.ashx?Prefix=NASDAQ&#038;Symbol=BLMN' alt='Analyst Recommendations for Bloomin` Brands (NASDAQ:BLMN)' title='Analyst Recommendations for Bloomin` Brands (NASDAQ:BLMN)' /></p>

			 	<!-- end inline unit -->
				<!-- end main text -->
				<!-- Invalidate Article -->
					 
				<!-- End Invalidate -->

<!--Begin Footer Opt-In-->
<p style="clear:both"><strong>Receive News &amp; Ratings for Bloomin' Brands Daily</strong> - Enter your email address below to receive a concise daily summary of the latest news and analysts' ratings for Bloomin' Brands and related companies with <a href="/daily-email-updates-basic/?symbol=NASDAQ:BLMN&c=Bloomin%27+Brands" rel="nofollow" style="text-decoration:underline;font-weight:bold">MarketBeat.com's FREE daily email newsletter</a>.</p>
<form method="get" action="https://www.marketbeat.com/newsletter/default.aspx">
<input type="email" id="BelowPostRegistrationEmail" name="RegisterEmail" placeholder="Your Email Address" class="signup" />
<input type="hidden" id="Hidden1" name="RegistrationCode" value="WKRB News-Footer" />
<input type="hidden" id="Hidden2" name="RegisterTicker" value="NASDAQ:BLMN" /><input class="button" type="submit" name="submit" onclick="return CheckEmail('BelowPostRegistrationEmail','ShowSuggestionFooter');" value="Sign-Up Now (Free)">
</form>
<div id="ShowSuggestionFooter"></div>
<!-- End Footer Opt-In -->

				</div> <!-- end: entry -->
				<!--/sse-->
				 				<!-- start article metadata -->
				 <div itemscope itemprop="image" itemtype="https://schema.org/ImageObject" style='display:none'>
 					<link itemprop="url" href="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?w=300&h=300&zc=1&src=https://www.marketbeat.com/logos/bloomin-brands-inc-logo.jpg" />
 					<meta itemprop="width" content="300">
 					<meta itemprop="height" content="300">
				 </div>
				<div itemscope itemprop="publisher" itemtype="https://schema.org/Organization" style="display:none">
 					<div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
 						<meta itemprop="url" content="https://wkrb13.com/wp-content/uploads/2018/03/wkrb13-01-2.png">
 						<meta itemprop="height" content="90">
						 <meta itemprop="width" content="290">
					 </div>
					<meta itemprop="name" content="WKRB News"/>
					<meta itemprop="url" content="https://wkrb13.com" />
 				</div>
				<!-- end article metadata -->
			</article>



<!-- More on MarketBeat -->
<iframe width="100%" height="600" scrolling="no" frameborder="no" src="https://www.marketbeat.com/scripts/MoreOnMarketBeatBelowPost.aspx"></iframe>
<!-- More on MarketBeat -->
<!-- IMS below post -->
		<div id="WKRBFinancialNews_ROS_BelowPost_1"></div><br><br>
<!-- end IMS below post -->		
			

			<nav id="prevnext"><!-- previous and next article links -->
				<a href="https://www.wkrb13.com/2020/07/05/brokerages-set-haymaker-acquisition-corp-nyseosw-pt-at-12-80.html" rel="prev"><div class="previous"><h4>&laquo; PREVIOUS</h4><p>Brokerages Set Haymaker Acquisition Corp. (NYSE:OSW) PT at $12.80</p></div></a>				<a href="https://www.wkrb13.com/2020/07/05/518-93-million-in-sales-expected-for-idex-co-nyseiex-this-quarter.html" rel="next"><div class="next"><h4>NEXT &raquo;</h4><p>$518.93 Million in Sales Expected for IDEX Co. (NYSE:IEX) This Quarter</p></div></a>			
			</nav><!-- end previous and next article links -->
			<div id="latest-news">
				<h2>Latest News</h2>
								 <div class="latest-news-item">
												<img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=wp-content/themes/newsalambre/images/image-pending.gif&amp;h=95&amp;w=95&amp;zc=1" height="95" width="95" alt="Beaxy Achieves Market Cap of $2.16 Million " />
						<br/>
				 <!--end: longthumb-->
						<a href="https://www.wkrb13.com/2020/07/05/beaxy-achieves-market-cap-of-2-16-million-bxy.html" rel="bookmark">Beaxy Achieves Market Cap of $2.16 Million </a>
				</div>
	 							 <div class="latest-news-item">
												<img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=wp-content/themes/newsalambre/images/image-pending.gif&amp;h=95&amp;w=95&amp;zc=1" height="95" width="95" alt="BoutsPro Achieves Market Cap of $149,074.76 " />
						<br/>
				 <!--end: longthumb-->
						<a href="https://www.wkrb13.com/2020/07/05/boutspro-achieves-market-cap-of-149074-76-bouts.html" rel="bookmark">BoutsPro Achieves Market Cap of $149,074.76 </a>
				</div>
	 							 <div class="latest-news-item">
												<img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=wp-content/themes/newsalambre/images/image-pending.gif&amp;h=95&amp;w=95&amp;zc=1" height="95" width="95" alt="EBCoin  Trading Up 10.4% Over Last 7 Days" />
						<br/>
				 <!--end: longthumb-->
						<a href="https://www.wkrb13.com/2020/07/05/ebcoin-ebc-trading-up-10-4-over-last-7-days.html" rel="bookmark">EBCoin  Trading Up 10.4% Over Last 7 Days</a>
				</div>
	 							 <div class="latest-news-item">
												<img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=wp-content/themes/newsalambre/images/image-pending.gif&amp;h=95&amp;w=95&amp;zc=1" height="95" width="95" alt="VNDC Reaches Market Cap of $4.35 Million " />
						<br/>
				 <!--end: longthumb-->
						<a href="https://www.wkrb13.com/2020/07/05/vndc-reaches-market-cap-of-4-35-million-vndc.html" rel="bookmark">VNDC Reaches Market Cap of $4.35 Million </a>
				</div>
	 							 <div class="latest-news-item">
												<img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=wp-content/themes/newsalambre/images/image-pending.gif&amp;h=95&amp;w=95&amp;zc=1" height="95" width="95" alt="Newscrypto  Market Cap Reaches $2.88 Million" />
						<br/>
				 <!--end: longthumb-->
						<a href="https://www.wkrb13.com/2020/07/05/newscrypto-nwc-market-cap-reaches-2-88-million.html" rel="bookmark">Newscrypto  Market Cap Reaches $2.88 Million</a>
				</div>
	 							 <div class="latest-news-item">
												<img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=wp-content/themes/newsalambre/images/image-pending.gif&amp;h=95&amp;w=95&amp;zc=1" height="95" width="95" alt="Qitmeer  Reaches 24-Hour Trading Volume of $46,838.00" />
						<br/>
				 <!--end: longthumb-->
						<a href="https://www.wkrb13.com/2020/07/05/qitmeer-hlc-reaches-24-hour-trading-volume-of-46838-00.html" rel="bookmark">Qitmeer  Reaches 24-Hour Trading Volume of $46,838.00</a>
				</div>
	 						</div><!-- end latest news -->
			

<!-- second ad spot -->

<br>
	</main> <!-- end main -->
	<div style="clear: both;"></div>
</div> <!-- end .width-limiter -->
<footer class="full-width">
			<div class="width-limiter">
				<div id="footer-info" class="add-padding">
					<nav class="navigation"><ul id="menu-category-menu-1" class="menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-31"><a href="https://www.wkrb13.com/category/markets">Markets</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-60"><a href="https://www.wkrb13.com/category/markets/analyst-articles-us">Ratings</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-54"><a href="https://www.wkrb13.com/category/markets/dividend-articles">Dividends</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-55"><a href="https://www.wkrb13.com/category/markets/earnings-articles-single">Earnings</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56"><a href="https://www.wkrb13.com/category/markets/insider-trades">Insider Trades</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24"><a href="https://www.wkrb13.com/category/markets/cryptocurrencies">Cryptocurrencies</a></li>
</ul></nav>					<span id="copyright">
						&copy; 2006-2020 <a href="https://www.wkrb13.com">WKRB News</a>
					</span>
				</div><!-- end #footer-info -->
			</div>	
		</footer>
		<script type='text/javascript' src='https://www.wkrb13.com/wp-includes/js/wp-embed.min.js?ver=5.3.4'></script>

<!-- MarketBeat News Network StatCounter Code -->
<script type="text/javascript">var sc_project=9021069; var sc_invisible=1; var sc_security="fdde5482"; var sc_https=1; </script>
<script type="text/javascript" src="https://www.statcounter.com/counter/counter.js"></script>
<noscript><img class="statcounter" src="https://c.statcounter.com/9021069/0/fdde5482/1/" height="1" width="1"></noscript>
<!-- End MarketBeat News Network StatCounter Code -->

<!-- Start of StatCounter Code for WKRB -->
<script type="text/javascript">
var sc_project=11650630; 
var sc_invisible=1; 
var sc_security="2798fb99"; 
var sc_https=1; 
var scJsHost = (("https:" == document.location.protocol) ? "https://secure." : "http://www.");
</script>
<script type="text/javascript" src="https://www.statcounter.com/counter/counter.js"></script><noscript><img class="statcounter" src="//c.statcounter.com/11650630/0/2798fb99/1/" alt="Web Analytics"></a></noscript>
<!-- End of StatCounter Code for WKRB -->
	


<!-- Begin Social Sharing -->
		<div style="top:25%;left:0;position:fixed;width:50px;z-index:20;box-sizing:content-box;" class="mobile-hide">
	<div style="background-color:#305891;border:0;width:30px;height:30px;padding:9px;box-sizing:content-box;"><a href="https://www.facebook.com/sharer/sharer.php?u=https://www.wkrb13.com/2020/07/05/brokerages-set-bloomin-brands-inc-nasdaqblmn-price-target-at-14-42.html" target="_blank"><img src="/images/social-fb.png" style="margin:0;padding:0;" alt="share news on Facebook"></a></div>
	<div style="background-color:#2CA8D2;border:0;width:30px;height:30px;padding:9px;box-sizing:content-box;"><a href="https://twitter.com/intent/tweet?text=Brokerages Set Bloomin&#8217; Brands Inc $NASDAQ:BLMN Price Target at $14.42 https://www.wkrb13.com/2020/07/05/brokerages-set-bloomin-brands-inc-nasdaqblmn-price-target-at-14-42.html" target="_blank"><img src="/images/social-tw.png" style="margin:0;padding:0;" alt="tweet this investment news"></a></div>
	<div style="background-color:#007BB6;border:0;width:30px;height:30px;padding:9px;box-sizing:content-box;"><a href="https://www.linkedin.com/cws/share?mini=true&url=https://www.wkrb13.com/2020/07/05/brokerages-set-bloomin-brands-inc-nasdaqblmn-price-target-at-14-42.html" target="_blank"><img src="/images/social-in.png" style="margin:0;padding:0;" alt="share on linkedin"></a></div>
	<div style="background-color:#89120a;border:0;width:30px;height:30px;padding:9px;box-sizing:content-box;"><a href="https://api.stocktwits.com/widgets/share?via=AnalystRatingsNetwork&body=Brokerages Set Bloomin&#8217; Brands Inc $NASDAQ:BLMN Price Target at $14.42 https://www.wkrb13.com/2020/07/05/brokerages-set-bloomin-brands-inc-nasdaqblmn-price-target-at-14-42.html" target="_blank"><img src="/images/social-st.png" style="margin:0;padding:0;box-sizing:content-box;" alt="share on StockTwits"></a></div>
	<div style="background-color:#FF1A00;border:0;width:30px;height:30px;padding:9px;box-sizing:content-box;"><a href="https://www.reddit.com/submit?url=https://www.wkrb13.com/2020/07/05/brokerages-set-bloomin-brands-inc-nasdaqblmn-price-target-at-14-42.html&title=Brokerages Set Bloomin&#8217; Brands Inc (NASDAQ:BLMN) Price Target at $14.42" target="_blank"><img src="/images/social-reddit.png" style="margin:0;padding:0;" alt="share on reddit"></a></div>
	</div>
	<!-- End Social Sharing -->

<!-- Begin Internal Tracking Pixel 2 -->
<script type='text/javascript'>document.write('<img src="https://www.american' + 'consumernews.net/scripts/viewcount.ashx?ArticleHistoryID=56534779&PostDate=2020-7-4&type=c&quarternary=1&id=875313&domain=www.wkrb13.com&referrer=' + encodeURIComponent(document.referrer) + '" />');</script>
<!-- End Internal Tracking Pixel 2-->

<!-- Begin comScore Tag -->
<script>
  var _comscore = _comscore || [];
  _comscore.push({ c1: "2", c2: "16807273" });
  (function() {
    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
    s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";
    el.parentNode.insertBefore(s, el);
  })();
</script>
<noscript>
  <img src="http://b.scorecardresearch.com/p?c1=2&c2=16807273&cv=2.0&cj=1" />
</noscript>
<!-- End comScore Tag -->

<!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-3019647-43"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-3019647-43');
</script>



</div>

	</body>
</html>