<!doctype html>
<html lang="en" style="display: block;min-width:1070px;">
<head>
<meta name="distribution" content="global" />
<meta name="robots" content="follow, all" />
 <meta content="text/html; charset=UTF-8" http-equiv="Content-Type" />
<meta name="google-site-verification" content="rcmqt74A6mEeS1xWVk3k3EMZbTi79AN2WJOyWXg0dJ4" />
<meta name="msvalidate.01" content="8D3F505D642C99EB26E45507554512BC" />
<meta name="norton-safeweb-site-verification" content="h3g5-5vc1eyl4ciu70dj759ufgj5zl-7d5xcemulxrycwbv3wlj320gvmjpuq6b5jmxx5rr7cxxk7csxy3xj4agugrktrdyd9qm3j-bhsojxzag5053lgfxnptkgp8o7" />
<meta name="viewport" content="width=1070">
<meta property="fb:pages" content="235821283247357" />



<!-- Escape from Frames -->
<script type="text/javascript">if(self==top){document.documentElement.style.display="block"}else{top.location=self.location}</script>
<link rel="stylesheet" href="https://www.wkrb13.com/wp-content/themes/newsalambre/style.css?v=10" type="text/css" media="screen" />
<link href="https://www.wkrb13.com/feed" rel="alternate" title="WKRB News RSS Feed" type="application/rss+xml" />
<link href="https://www.wkrb13.com/feed/atom" rel="alternate" title="WKRB News Atom Feed" type="application/atom+xml" />
<link href="https://www.wkrb13.com/xmlrpc.php" rel="pingback" />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://www.wkrb13.com/wp-includes/css/dist/block-library/style.min.css?ver=5.5.3' type='text/css' media='all' />
<link rel="https://api.w.org/" href="https://www.wkrb13.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.wkrb13.com/wp-json/wp/v2/posts/2389451" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.wkrb13.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.wkrb13.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Medallion Financial (NASDAQ:MFIN) Issues Quarterly  Earnings Results' href='https://www.wkrb13.com/2020/11/09/medallion-financial-nasdaqmfin-issues-quarterly-earnings-results.html' />
<link rel='next' title='PhoenixDAO Price Hits $0.0171 on Top Exchanges (PHNX)' href='https://www.wkrb13.com/2020/11/09/phoenixdao-price-hits-0-0171-on-top-exchanges-phnx.html' />
<meta name="generator" content="WordPress 5.5.3" />
<link rel="canonical" href="https://www.wkrb13.com/2020/11/09/micromines-tops-24-hour-trading-volume-of-57-00-micro.html" />
<link rel='shortlink' href='https://www.wkrb13.com/?p=2389451' />
<link rel="alternate" type="application/json+oembed" href="https://www.wkrb13.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.wkrb13.com%2F2020%2F11%2F09%2Fmicromines-tops-24-hour-trading-volume-of-57-00-micro.html" />
<link rel="alternate" type="text/xml+oembed" href="https://www.wkrb13.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.wkrb13.com%2F2020%2F11%2F09%2Fmicromines-tops-24-hour-trading-volume-of-57-00-micro.html&#038;format=xml" />
<link rel="amphtml" href="https://www.wkrb13.com/2020/11/09/micromines-tops-24-hour-trading-volume-of-57-00-micro.html/amp" /><link rel="icon" href="https://www.wkrb13.com/wp-content/uploads/2018/03/wkrb13-03-150x150.png" sizes="32x32" />
<link rel="icon" href="https://www.wkrb13.com/wp-content/uploads/2018/03/wkrb13-03.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.wkrb13.com/wp-content/uploads/2018/03/wkrb13-03.png" />
<meta name="msapplication-TileImage" content="https://www.wkrb13.com/wp-content/uploads/2018/03/wkrb13-03.png" />

<!-- Start Meta Data -->
<title>Micromines Tops 24-Hour Trading Volume of $57.00 (MICRO) - WKRB News</title>
<meta name="description" content="Micromines (CURRENCY:MICRO) traded 2.3% higher against the dollar during the one day period ending at 7:00 AM ET on November 9th. Micromines has a total market cap of $17,852.47 and approximately $57.00 worth of Micromines was traded on exchanges in the last day. In the last week, Micromines has traded 19.6% lower against the dollar. [&hellip;]" />
<meta name="author" content="Jim Brewer">
<meta name="news_keywords" content="Micromines,CURRENCY:MICRO,MICRO" />
<meta name="keywords" content="Micromines,CURRENCY:MICRO,MICRO" />
<meta name="ticker" content="CURRENCY:MICRO" />
<meta name="contentType" content="article">

<!-- Twitter Card Data -->
<meta name="twitter:card" content="summary"/>
<meta name="twitter:site" content="@RatingsNetwork" />
<meta name="twitter:title" content="Micromines Tops 24-Hour Trading Volume of $57.00 (MICRO)"/>
<meta name="twitter:description" content="Micromines (CURRENCY:MICRO) traded 2.3% higher against the dollar during the one day period ending at 7:00 AM ET on November 9th. Micromines has a total market cap of $17,852.47 and approximately $57.00 worth of Micromines was traded on exchanges in the last day. In the last week, Micromines has traded 19.6% lower against the dollar. [&hellip;]" />
<meta name="twitter:creator" content="@RatingsNetwork" />
<meta name="twitter:image" content="wp-content/themes/newsalambre/images/image-pending.gif" />

<!-- Open Graph Data -->
<meta property="og:title" content="Micromines Tops 24-Hour Trading Volume of $57.00 (MICRO)" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.wkrb13.com/2020/11/09/micromines-tops-24-hour-trading-volume-of-57-00-micro.html" />
<meta property="og:image" content="wp-content/themes/newsalambre/images/image-pending.gif" />
<meta property="og:description" content="Micromines (CURRENCY:MICRO) traded 2.3% higher against the dollar during the one day period ending at 7:00 AM ET on November 9th. Micromines has a total market cap of $17,852.47 and approximately $57.00 worth of Micromines was traded on exchanges in the last day. In the last week, Micromines has traded 19.6% lower against the dollar. [&hellip;]" />
<meta property="og:site_name" content="WKRB News" />
<meta property="og:locale" content="en_US" />

<!-- OG Article Template -->
<meta property="article:published_time" content="2020-11-09T12:54:41+0000" />
<meta property="article:modified_time" content="2020-11-09T12:54:41+0000" />
<meta property="article:tag" content="CURRENCY:MICRO" />
<meta property="article:tag" content="Micromines,CURRENCY:MICRO,MICRO" />
<meta property="article:section" content="Markets" />

<!-- Google meta is in the body-->

<!-- End Meta Data -->

	
<script type='text/javascript'>var PopupAdChannel=''; </script>

  <link rel="manifest" href="/manifest.json">
  <script src="https://cdn.onesignal.com/sdks/OneSignalSDK.js"></script>
  <script>
  	function registerUserChange(action) {
		OneSignal.getUserId( function(userId) {
			OneSignalIdString = userId;
			var Domain = 'wkrb13.com';
			var url = "https://www.marketbeat.com/scripts/OneSignalTracking.ashx?OneSignalID=" + OneSignalIdString + "&domain=" + Domain + "&action=" + action;
			var xhr = new XMLHttpRequest();
			xhr.open('GET', url);
			xhr.onload = function () {
				if (xhr.status !== 200) {
					console.log('GET failed.  Returned status of ' + xhr.status);
				}
			};
			xhr.send();
		});
	}
    var OneSignal = window.OneSignal || [];
    OneSignal.push(["init", {
      appId: "27539f7d-08b9-4089-9eac-48d0d5b908a5",
      safari_web_id: 'web.onesignal.auto.54cd441e-7f12-4aed-9845-f98eb5c10ecb', 
      autoRegister: false,
      notifyButton: {
        enable: false /* Set to false to hide */
      },
 welcomeNotification: {
        "title": "Join Wall Street's Brightest Minds.",
        "message": "Receive research in your inbox from top analysts, before the market opens. Click here to learn how.",
         "url": "https://www.marketbeat.com/subscribe/subscribe.aspx?ReferralType=OneSignalThankYou&ProductCode=1997t"
    }
    },
		OneSignal.once('subscriptionChange', function (isSubscribed) {
			if(isSubscribed) {
				registerUserChange("subscribe");
			}
			else {
				registerUserChange("unsubscribe");
			}
			
		  })
	]);
	if((navigator.userAgent.toLowerCase().indexOf('firefox') > -1)||((navigator.userAgent.toLowerCase().indexOf('safari') > -1)&&(!(navigator.userAgent.toLowerCase().indexOf('chrome') > -1)))){
		OneSignal.showSlidedownPrompt();
	} else {
		OneSignal.showNativePrompt();		
	}	  
  </script>
	
<script type="text/javascript">var vbnfgha = '211626'; var ertdfga = '13739-bup-ac'; var qhyuioa = '53938'; var AdClientID = qhyuioa + vbnfgha + ertdfga; AdClientID = AdClientID.split("").reverse().join("");</script>

<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({
          google_ad_client: AdClientID,
          enable_page_level_ads: true
     });
</script>
<!-- Start IMS -->
<script type="text/javascript">
		var apntag = apntag || {};
		apntag.anq = apntag.anq || [];
		(function() {
			var d = document, e = d.createElement('script'), p = d.getElementsByTagName('head')[0];
			e.type = 'text/javascript';  e.async = true;
			e.src = '//acdn.adnxs.com/ast/ast.js';
			p.insertBefore(e, p.firstChild);
		})();

		
		apntag.anq.push(function() {
			apntag.setPageOpts({
				member: 6989
			});
		});

		apntag.anq.push(function() {

      		apntag.defineTag({
				tagId: 13481205,
				sizes: [[300,250],[300,600],[300,1050]],
				keywords: {'position': ['RightRail_1']},
				targetId: 'WKRBFinancialNews_ROS_RightRail_1'
			});
					});

		apntag.anq.push(function() {
			apntag.loadTags();
		});
		</script>
	
<script type="text/javascript">
(function() {
window.advBidxc = window.advBidxc || {};
window.advBidxc.startTime = new Date().getTime();
function loadScript(tagSrc) {
var scriptTag = document.createElement('script'),
placeTag = document.getElementsByTagName("script")[0];
scriptTag.type = 'text/javascript';
scriptTag.async = true;
scriptTag.src = tagSrc;
placeTag.parentNode.insertBefore(scriptTag, placeTag);
}
var mnSrc = '//hbx.media.net/bidexchange.js?cid=8CU2C156D&version=5.1' + '&dn=' +
window.location.hostname;
loadScript(mnSrc);
})();
</script>
<!-- End IMS --> 

	<script type="text/javascript" src="https://www.marketbeat.com/Scripts/lowerrightad.js?v=9"></script>

</head>
<body>
<div id="wrap">

<!-- Start MarketBeat Modern Popup -->
<link rel="stylesheet" type="text/css" media="all" href="https://www.marketbeat.com/scripts/modal/modernpopup.css?v=11"/>
<script type="text/javascript" src="https://www.marketbeat.com/scripts/modal/modernpopup.js?v=52"></script>

	<script type="text/javascript">LoadPopupRatings('ModernNonMarketsPopup-WKRB News', 'wkrb13.com');</script>
<!-- End MarketBeat Modern Popup -->
	
<header>
	<div id="top-bar">
		<div class="width-limiter">
				<!-- top nav bar -->
				<nav class="navigation"><ul id="menu-top-bar" class="menu"><li id="menu-item-19" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-19"><a href="https://wkrb13.com">Home</a></li>
<li id="menu-item-18" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-18"><a href="https://www.wkrb13.com/about">About</a></li>
<li id="menu-item-17" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-17"><a href="https://www.wkrb13.com/daily-email-updates-basic">Daily Email Updates</a></li>
<li id="menu-item-47" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-47"><a href="https://www.wkrb13.com/privacy-policy">Privacy Policy</a></li>
</ul></nav>				<form id="searchform" action="https://www.wkrb13.com/" method="get">
					<div id="search">
						<input id="s" class="searchinput" name="s" onclick="this.value='';" type="text" />
						<input class="searchsubmit" type="submit" value="Search" />
					</div>
				</form><!-- end: searchform -->
		</div><!-- end: width-limiter in top-bar -->
	</div><!-- end: top-bar -->
	<div class="width-limiter add-padding"><!-- start: width-limiter with logo and space for alternate header unit -->
		<a class="logo-link" href="https://www.wkrb13.com"><img id="logo" src="/wp-content/uploads/2018/03/wkrb13-01-2.png" alt="WKRB News and Analysis logo"></a>

<!-- Begin Header Unit -->
<div id="AlternateHeaderUnit">
		
		<iframe src="https://marketbeat.com/scripts/HeaderAdNewsSites.ashx" width="728" height="90" frameborder="no" scrolling="no"></iframe>
			</div> 

<!-- End Header Unit-->
	</div> <!-- end: width-limiter with logo and space for alternate header unit -->
	<div id="menu">
		<div class="width-limiter" id="nav-main">
			<!-- start main category menu -->
			<nav class="navigation"><ul id="menu-category-menu" class="menu"><li id="menu-item-31" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-31"><a href="https://www.wkrb13.com/category/markets">Markets</a></li>
<li id="menu-item-60" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-60"><a href="https://www.wkrb13.com/category/markets/analyst-articles-us">Ratings</a></li>
<li id="menu-item-54" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-54"><a href="https://www.wkrb13.com/category/markets/dividend-articles">Dividends</a></li>
<li id="menu-item-55" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-55"><a href="https://www.wkrb13.com/category/markets/earnings-articles-single">Earnings</a></li>
<li id="menu-item-56" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56"><a href="https://www.wkrb13.com/category/markets/insider-trades">Insider Trades</a></li>
<li id="menu-item-24" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-24"><a href="https://www.wkrb13.com/category/markets/cryptocurrencies">Cryptocurrencies</a></li>
</ul></nav>		</div> <!-- end: width-limiter for menu -->
	</div> <!-- end: menu -->
</header> <!-- end: header -->
	<div class="width-limiter main-content">
		
<aside>
	
<iframe src="https://marketbeat.com/scripts/MoreOnMarketBeat.aspx" width="336" height="600" frameborder="no"></iframe><br><br>	
	
<div class="ad336x280" style='width:336px;height:280px'>
<!-- Network Wide AdSense Unit - Top Sidebar Position -->
<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-9373162611283935" data-ad-slot="1875628183" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>(adsbygoogle = window.adsbygoogle || []).push({});</script>
<!-- End AdSense Unit -->
	</div>
<!-- end first square unit -->

<div class="ad336x280" style='width:336px;height:280px'>
<!-- Network Wide AdSense Unit - Middle Sidebar Position -->
<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-9373162611283935" data-ad-slot="9445683366" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>(adsbygoogle = window.adsbygoogle || []).push({});</script>
<!-- End AdSense Unit -->
	</div>
	
<!-- end second square unit -->


<!-- OptIn Form -->

<!-- Start Sidebar Registration -->
    <div class="sidebar-email">
                        <h3>Daily Ratings &amp; News for Micromines</h3>
        	Complete the form below to receive the latest headlines and analysts' recommendations for Micromines with our free daily email newsletter:<br/>
        <form method="get" action="https://www.marketbeat.com/newsletter/default.aspx">
        <input id="RegisterEmailSidebar" name="RegisterEmail" type="email" placeholder="Your Email Address">
        <input type="hidden" id="Hidden1" name="RegistrationCode" value="WKRB News-Sidebar">
        <input type="hidden" id="Hidden2" name="RegisterTicker" value="CURRENCY:MICRO" />        <input type="submit" name="submit" onclick="return CheckEmail('RegisterEmailSidebar', 'ShowSuggestionSidebar');" value="Subscribe Now (Free Sign-Up)" class="button" style="width:336px;height:30px">
    <div id="ShowSuggestionSidebar" style="padding-top:7px"></div>
    </form>
    </div>

<!-- End Sidebar Registration -->


<div>
<a class="twitter-follow-button"
  href="https://twitter.com/wkrbnews"
  data-size="large">
Follow @WKRBNews</a>
<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script>
<br>
<br>

<iframe src="https://www.facebook.com/plugins/like.php?href=https%3A%2F%2Fwww.facebook.com%2Fwkrbnews%2F&width=336&layout=standard&action=like&size=small&show_faces=true&share=true&height=80&appId" width="336" height="80" style="border:none;overflow:hidden" scrolling="no" frameborder="0" allowTransparency="true"></iframe>

</div>

<!-- Start IMS -->
<div id="WKRBFinancialNews_ROS_RightRail_1" class="text-center">
			<script type="text/javascript">
			apntag.anq.push(function() {
				apntag.showTag('WKRBFinancialNews_ROS_RightRail_1');
			});
			</script>
		</div>
<!-- End IMS --> 


<!-- start Recent Posts -->
        <br/>
        <div>
        <h3>Recent Posts</h3>
            <ul>
                        <li class="recent-posts"><a href="https://www.wkrb13.com/2020/11/09/brokerages-set-national-oilwell-varco-inc-nysenov-price-target-at-14-71.html">Brokerages Set National Oilwell Varco, Inc. (NYSE:NOV) Price Target at $14.71</a></li>
                        <li class="recent-posts"><a href="https://www.wkrb13.com/2020/11/09/avalara-inc-nyseavlr-receives-155-42-consensus-target-price-from-analysts.html">Avalara Inc (NYSE:AVLR) Receives $155.42 Consensus Target Price from Analysts</a></li>
                        <li class="recent-posts"><a href="https://www.wkrb13.com/2020/11/09/west-japan-railway-otcmktswjryy-given-consensus-recommendation-of-hold-by-analysts.html">West Japan Railway (OTCMKTS:WJRYY) Given Consensus Recommendation of &#8220;Hold&#8221; by Analysts</a></li>
                        <li class="recent-posts"><a href="https://www.wkrb13.com/2020/11/09/analysts-set-griffon-co-nysegff-pt-at-29-50.html">Analysts Set Griffon Co. (NYSE:GFF) PT at $29.50</a></li>
                        <li class="recent-posts"><a href="https://www.wkrb13.com/2020/11/09/aviva-plc-otcmktsavviy-receives-average-rating-of-hold-from-analysts.html">Aviva plc (OTCMKTS:AVVIY) Receives Average Rating of &#8220;Hold&#8221; from Analysts</a></li>
                        <li class="recent-posts"><a href="https://www.wkrb13.com/2020/11/09/franco-nevada-co-nysefnv-receives-170-65-average-target-price-from-analysts.html">Franco-Nevada Co. (NYSE:FNV) Receives $170.65 Average Target Price from Analysts</a></li>
                        <li class="recent-posts"><a href="https://www.wkrb13.com/2020/11/09/engie-sa-otcmktsengiy-receives-average-rating-of-buy-from-analysts.html">Engie SA (OTCMKTS:ENGIY) Receives Average Rating of &#8220;Buy&#8221; from Analysts</a></li>
                        <li class="recent-posts"><a href="https://www.wkrb13.com/2020/11/09/mgic-investment-corp-nysemtg-receives-12-19-average-pt-from-analysts.html">MGIC Investment Corp. (NYSE:MTG) Receives $12.19 Average PT from Analysts</a></li>
                        <li class="recent-posts"><a href="https://www.wkrb13.com/2020/11/09/kaleido-biosciences-nasdaqkldo-issues-quarterly-earnings-results.html">Kaleido Biosciences (NASDAQ:KLDO) Issues Quarterly  Earnings Results</a></li>
                        <li class="recent-posts"><a href="https://www.wkrb13.com/2020/11/09/cross-country-healthcare-inc-nasdaqccrn-receives-8-84-average-target-price-from-analysts.html">Cross Country Healthcare, Inc. (NASDAQ:CCRN) Receives $8.84 Average Target Price from Analysts</a></li>
                        <li class="recent-posts"><a href="https://www.wkrb13.com/2020/11/09/jounce-therapeutics-nasdaqjnce-releases-earnings-results-misses-estimates-by-0-36-eps.html">Jounce Therapeutics (NASDAQ:JNCE) Releases  Earnings Results, Misses Estimates By $0.36 EPS</a></li>
                        <li class="recent-posts"><a href="https://www.wkrb13.com/2020/11/09/petroleo-brasileiro-s-a-petrobras-nysepbr-announces-earnings-results-beats-estimates-by-0-20-eps.html">Petróleo Brasileiro S.A. &#8211; Petrobras (NYSE:PBR) Announces  Earnings Results, Beats Estimates By $0.20 EPS</a></li>
                        <li class="recent-posts"><a href="https://www.wkrb13.com/2020/11/09/louisiana-pacific-nyselpx-posts-quarterly-earnings-results-beats-estimates-by-0-11-eps.html">Louisiana-Pacific (NYSE:LPX) Posts Quarterly  Earnings Results, Beats Estimates By $0.11 EPS</a></li>
                        <li class="recent-posts"><a href="https://www.wkrb13.com/2020/11/09/mylan-nasdaqmyl-posts-quarterly-earnings-results-beats-estimates-by-0-15-eps.html">Mylan (NASDAQ:MYL) Posts Quarterly  Earnings Results, Beats Estimates By $0.15 EPS</a></li>
                        <li class="recent-posts"><a href="https://www.wkrb13.com/2020/11/09/matrix-service-nasdaqmtrx-announces-earnings-results.html">Matrix Service (NASDAQ:MTRX) Announces  Earnings Results</a></li>
                        <li class="recent-posts"><a href="https://www.wkrb13.com/2020/11/09/lifevantage-nasdaqlfvn-releases-earnings-results-beats-expectations-by-0-09-eps.html">LifeVantage (NASDAQ:LFVN) Releases  Earnings Results, Beats Expectations By $0.09 EPS</a></li>
                        <li class="recent-posts"><a href="https://www.wkrb13.com/2020/11/09/iveric-bio-nasdaqisee-announces-earnings-results-misses-estimates-by-0-06-eps.html">IVERIC bio (NASDAQ:ISEE) Announces  Earnings Results, Misses Estimates By $0.06 EPS</a></li>
                        <li class="recent-posts"><a href="https://www.wkrb13.com/2020/11/09/five-prime-therapeutics-nasdaqfprx-announces-quarterly-earnings-results.html">Five Prime Therapeutics (NASDAQ:FPRX) Announces Quarterly  Earnings Results</a></li>
                        <li class="recent-posts"><a href="https://www.wkrb13.com/2020/11/09/alliant-energy-nyselnt-announces-quarterly-earnings-results.html">Alliant Energy (NYSE:LNT) Announces Quarterly  Earnings Results</a></li>
                        <li class="recent-posts"><a href="https://www.wkrb13.com/2020/11/09/regis-nysergs-posts-earnings-results.html">Regis (NYSE:RGS) Posts  Earnings Results</a></li>
                        </ul>
        </div>  

<!-- end recent posts -->
</aside><!--end #sidebar-->
		<main>
			 <article itemscope itemtype="http://schema.org/NewsArticle">
				
				<link itemprop="mainEntityOfPage" href="https://www.wkrb13.com/2020/11/09/micromines-tops-24-hour-trading-volume-of-57-00-micro.html" />
				<h1 itemprop="headline" class="page-title">Micromines Tops 24-Hour Trading Volume of $57.00 (MICRO)</h1>
				
				<p class="postmeta">
					Posted by <span itemprop="author" itemscope itemtype="https://schema.org/Person"><span itemprop="name"><a href="https://www.wkrb13.com/author/jimb" title="Posts by Jim Brewer" rel="author">Jim Brewer</a></span></span> on <span itemprop="datePublished dateModified" content="2020-11-09T12:54:41+0000">Nov 9th, 2020</span>
				</p><!--end .postmeta-->
				<!--sse-->
				<div class="entry" itemprop="articleBody"> 
				<!-- start main text -->
					
					<p>Micromines (CURRENCY:MICRO) traded 2.3% higher  against the dollar during the one day period ending at 7:00 AM ET on November 9th. <a href='https://www.marketbeat.com/cryptocurrencies/micromines/'>Micromines</a> has a total market cap of $17,852.47 and approximately $57.00 worth of Micromines was traded on exchanges in the last day. In the last week, Micromines has traded 19.6% lower  against the dollar. One Micromines token can now be purchased for $0.0000 or 0.00000000 BTC on cryptocurrency exchanges including  Crex24, Hotbit,  Mercatox and  Bilaxy. </p>
<p>Here&#8217;s how other cryptocurrencies have performed in the last day:</p>					

<form method="get" action="https://www.marketbeat.com/newsletter/default.aspx" style="border-bottom-width: 1px; border-color: #D2D2D2; border-style: solid; border-top-width: 1px; margin-bottom: 24px; margin-top: 12px; padding: 12px 0;border-right:none;border-left:none;clear:both;">
    <input type="hidden" id="Hidden1" name="RegistrationCode" value="InPost-WKRB News"  />
    <input type="hidden" id="Hidden2" name="RegisterTicker" value="CURRENCY:MICRO" />    <label for="InPostRegistrationEmail">Get <b>Micromines</b> alerts:</label>
    <div style="display:inline-block;"><input id="InPostRegistrationEmail" name="RegisterEmail" type="email" placeholder="Enter Your Email Address" style="border: 1px solid #D2D2D2;font-size: 12px;line-height: 18px;margin: 0;min-width: 200px; padding: 4px;" /><input type="submit" name="submit" onclick="return CheckEmail('InPostRegistrationEmail','ShowSuggestionInPost');" value="Submit" style="-webkit-appearance: none;-moz-appearance: none;appearance: none;background-color: #1361A2;border: 1px solid #1361A2;border-bottom-right-radius: .5em;border-top-right-radius: .5em;color: #fff;font-size: 12px;font-weight: 700;line-height: 18px;padding: 4px 18px"></input></div>
</form>
<div id="ShowSuggestionInPost"></div>


<ul>
<li>Tether (USDT) traded down 0% against the dollar and now trades at $1.00 or 0.00006407 BTC.</li>
<li>XRP (XRP) traded 0% higher  against the dollar and now trades at $0.25 or 0.00001621 BTC.</li>
<li>Chainlink (LINK) traded up 1.4% against the dollar and now trades at $12.66 or 0.00081061 BTC.</li>
<li>Binance Coin (BNB) traded up 0.6% against the dollar and now trades at $28.42 or 0.00181952 BTC.</li>
<li>Polkadot (DOT) traded up 0.9% against the dollar and now trades at $4.40 or 0.00028175 BTC.</li>
<li>Bitcoin SV (BSV) traded 1.3% higher  against the dollar and now trades at $164.33 or 0.01051940 BTC.</li>
<li>InnovativeBioresearchClassic (INNBCL) traded 20.6% higher  against the dollar and now trades at $0.0000 or 0.00000000 BTC.</li>
<li>TRON (TRX) traded down 0.6% against the dollar and now trades at $0.0253 or 0.00000162 BTC.</li>
<li>IZE (IZE) traded up 8% against the dollar and now trades at $0.42 or 0.00002686 BTC.</li>
<li>Stellar (XLM) traded 1% lower  against the dollar and now trades at $0.0809 or 0.00000518 BTC.</li>
</ul>
<p><strong>About Micromines</strong></p>
<p>
		  <div style="float:left;padding-right: 10px;padding-bottom:10px;padding-top:10px;width:340px;">
<iframe src="https://marketbeat.com/scripts/336x280AdNewsSites.ashx" width="336" height="280" frameborder="no"></iframe>
                 </div>


                 Micromines&#8217; total supply is 18,000,000,000 tokens and its circulating supply is 17,999,261,364 tokens. Micromines&#8217; official message board is <a rel='nofollow' href='https://medium.com/@micromines'>medium.com/@micromines</a>. Micromines&#8217; official website is <a rel='nofollow' href='https://micromines.co/'>micromines.co</a>. Micromines&#8217; official Twitter account is <a rel='nofollow' href='https://twitter.com/Microminestoken'>@Microminestoken</a>. </p>
<p><strong>Buying and Selling Micromines</strong></p>
<p>Micromines can be purchased on these cryptocurrency exchanges:  Mercatox,  Bilaxy, Hotbit and  Crex24.  It is usually not currently possible to buy alternative cryptocurrencies such as Micromines directly using U.S. dollars. Investors seeking to acquire Micromines should first buy Bitcoin or Ethereum using an exchange that deals in U.S. dollars such as Gemini, Changelly or <a target='_blank' href='https://www.coinbase.com/join/52afc5ac562b15091600001d' rel="noopener noreferrer">Coinbase</a>. Investors can then use their newly-acquired Bitcoin or Ethereum to buy Micromines using one of the exchanges listed above. </p>
<p><script type="text/javascript" src="https://s3.tradingview.com/tv.js"></script><script type ="text/javascript">new TradingView.widget(  {  "width": 600,  "height": 400,  "symbol": "MICROUSD",  "interval": "D",  "timezone": "Etc/UTC",  "theme": "Light",  "style": "1",  "locale": "en",  "toolbar_bg": "#f1f3f6",  "enable_publishing": false,  "allow_symbol_change": true,  "referral_id": "2588"}  ); </script></p>
<p> <!--ViewCount:ArticleHistoryID=64865351&PostDate=2020-11-9&type=x&id=1530473--><!--Keyword: Micromines,CURRENCY:MICRO,MICRO--></p>

			 	<!-- end inline unit -->
				<!-- end main text -->
				<!-- Invalidate Article -->
					 
				<!-- End Invalidate -->

<!--Begin Footer Opt-In-->
<p style="clear:both"><strong>Receive News &amp; Updates for Micromines Daily</strong> - Enter your email address below to receive a concise daily summary of the latest news and updates for Micromines and related cryptocurrencies with <a href="https://www.marketbeat.com/cryptocurrencies/newsletter/?symbol=CURRENCY:MICRO&utm_source=MarketBeatPopup&utm_medium=MarketBeatPopup" style="text-decoration:underline;font-weight:bold">MarketBeat.com's FREE CryptoBeat newsletter</a>.</p>
<form method="get" action="https://www.marketbeat.com/newsletter/default.aspx">
<input type="email" id="BelowPostRegistrationEmail" name="RegisterEmail" placeholder="Your Email Address" class="signup" />
<input type="hidden" id="Hidden1" name="RegistrationCode" value="WKRB News-Footer" />
<input type="hidden" id="Hidden2" name="RegisterTicker" value="CURRENCY:MICRO" /><input class="button" type="submit" name="submit" onclick="return CheckEmail('BelowPostRegistrationEmail','ShowSuggestionFooter');" value="Sign-Up Now (Free)">
</form>
<div id="ShowSuggestionFooter"></div>
<!-- End Footer Opt-In -->

				</div> <!-- end: entry -->
				<!--/sse-->
				 				<!-- start article metadata -->
				 <div itemscope itemprop="image" itemtype="https://schema.org/ImageObject" style='display:none'>
 					<link itemprop="url" href="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?w=300&h=300&zc=1&src=wp-content/themes/newsalambre/images/image-pending.gif" />
 					<meta itemprop="width" content="300">
 					<meta itemprop="height" content="300">
				 </div>
				<div itemscope itemprop="publisher" itemtype="https://schema.org/Organization" style="display:none">
 					<div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
 						<meta itemprop="url" content="https://wkrb13.com/wp-content/uploads/2018/03/wkrb13-01-2.png">
 						<meta itemprop="height" content="90">
						 <meta itemprop="width" content="290">
					 </div>
					<meta itemprop="name" content="WKRB News"/>
					<meta itemprop="url" content="https://wkrb13.com" />
 				</div>
				<!-- end article metadata -->
			</article>



<!-- More on MarketBeat -->
<iframe width="100%" height="600" scrolling="no" frameborder="no" src="https://www.marketbeat.com/scripts/MoreOnMarketBeatBelowPost.aspx"></iframe>
<!-- More on MarketBeat -->
<!-- IMS below post -->
		<div id="WKRBFinancialNews_ROS_BelowPost_1"></div><br><br>
<!-- end IMS below post -->		
			

			<nav id="prevnext"><!-- previous and next article links -->
				<a href="https://www.wkrb13.com/2020/11/09/medallion-financial-nasdaqmfin-issues-quarterly-earnings-results.html" rel="prev"><div class="previous"><h4>&laquo; PREVIOUS</h4><p>Medallion Financial (NASDAQ:MFIN) Issues Quarterly  Earnings Results</p></div></a>				<a href="https://www.wkrb13.com/2020/11/09/phoenixdao-price-hits-0-0171-on-top-exchanges-phnx.html" rel="next"><div class="next"><h4>NEXT &raquo;</h4><p>PhoenixDAO Price Hits $0.0171 on Top Exchanges (PHNX)</p></div></a>			
			</nav><!-- end previous and next article links -->
			<div id="latest-news">
				<h2>Latest News</h2>
								 <div class="latest-news-item">
												<img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/4cbb6ea0c3d1.gif&amp;h=95&amp;w=95&amp;zc=1" height="95" width="95" alt="Brokerages Set National Oilwell Varco, Inc.  Price Target at $14.71" />
						<br/>
				 <!--end: longthumb-->
						<a href="https://www.wkrb13.com/2020/11/09/brokerages-set-national-oilwell-varco-inc-nysenov-price-target-at-14-71.html" rel="bookmark">Brokerages Set National Oilwell Varco, Inc.  Price Target at $14.71</a>
				</div>
	 							 <div class="latest-news-item">
												<img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/avalara-inc-logo.png&amp;h=95&amp;w=95&amp;zc=1" height="95" width="95" alt="Avalara Inc  Receives $155.42 Consensus Target Price from Analysts" />
						<br/>
				 <!--end: longthumb-->
						<a href="https://www.wkrb13.com/2020/11/09/avalara-inc-nyseavlr-receives-155-42-consensus-target-price-from-analysts.html" rel="bookmark">Avalara Inc  Receives $155.42 Consensus Target Price from Analysts</a>
				</div>
	 							 <div class="latest-news-item">
												<img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/generic-stocks.jpg&amp;h=95&amp;w=95&amp;zc=1" height="95" width="95" alt="West Japan Railway  Given Consensus Recommendation of &#8220;Hold&#8221; by Analysts" />
						<br/>
				 <!--end: longthumb-->
						<a href="https://www.wkrb13.com/2020/11/09/west-japan-railway-otcmktswjryy-given-consensus-recommendation-of-hold-by-analysts.html" rel="bookmark">West Japan Railway  Given Consensus Recommendation of &#8220;Hold&#8221; by Analysts</a>
				</div>
	 							 <div class="latest-news-item">
												<img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/griffon-co-logo.jpg&amp;h=95&amp;w=95&amp;zc=1" height="95" width="95" alt="Analysts Set Griffon Co.  PT at $29.50" />
						<br/>
				 <!--end: longthumb-->
						<a href="https://www.wkrb13.com/2020/11/09/analysts-set-griffon-co-nysegff-pt-at-29-50.html" rel="bookmark">Analysts Set Griffon Co.  PT at $29.50</a>
				</div>
	 							 <div class="latest-news-item">
												<img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/aviva-plc-logo.png&amp;h=95&amp;w=95&amp;zc=1" height="95" width="95" alt="Aviva plc  Receives Average Rating of &#8220;Hold&#8221; from Analysts" />
						<br/>
				 <!--end: longthumb-->
						<a href="https://www.wkrb13.com/2020/11/09/aviva-plc-otcmktsavviy-receives-average-rating-of-hold-from-analysts.html" rel="bookmark">Aviva plc  Receives Average Rating of &#8220;Hold&#8221; from Analysts</a>
				</div>
	 							 <div class="latest-news-item">
												<img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/franco-nev-corp-common-(canada)-logo.jpg&amp;h=95&amp;w=95&amp;zc=1" height="95" width="95" alt="Franco-Nevada Co.  Receives $170.65 Average Target Price from Analysts" />
						<br/>
				 <!--end: longthumb-->
						<a href="https://www.wkrb13.com/2020/11/09/franco-nevada-co-nysefnv-receives-170-65-average-target-price-from-analysts.html" rel="bookmark">Franco-Nevada Co.  Receives $170.65 Average Target Price from Analysts</a>
				</div>
	 						</div><!-- end latest news -->
			

<!-- second ad spot -->

<br>
	</main> <!-- end main -->
	<div style="clear: both;"></div>
</div> <!-- end .width-limiter -->
<footer class="full-width">
			<div class="width-limiter">
				<div id="footer-info" class="add-padding">
					<nav class="navigation"><ul id="menu-category-menu-1" class="menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-31"><a href="https://www.wkrb13.com/category/markets">Markets</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-60"><a href="https://www.wkrb13.com/category/markets/analyst-articles-us">Ratings</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-54"><a href="https://www.wkrb13.com/category/markets/dividend-articles">Dividends</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-55"><a href="https://www.wkrb13.com/category/markets/earnings-articles-single">Earnings</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56"><a href="https://www.wkrb13.com/category/markets/insider-trades">Insider Trades</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-24"><a href="https://www.wkrb13.com/category/markets/cryptocurrencies">Cryptocurrencies</a></li>
</ul></nav>					<span id="copyright">
						&copy; 2006-2020 <a href="https://www.wkrb13.com">WKRB News</a>
					</span>
				</div><!-- end #footer-info -->
			</div>	
		</footer>
		<script type='text/javascript' src='https://www.wkrb13.com/wp-includes/js/wp-embed.min.js?ver=5.5.3' id='wp-embed-js'></script>

<!-- MarketBeat News Network StatCounter Code -->
<script type="text/javascript">var sc_project=9021069; var sc_invisible=1; var sc_security="fdde5482"; var sc_https=1; </script>
<script type="text/javascript" src="https://www.statcounter.com/counter/counter.js"></script>
<noscript><img class="statcounter" src="https://c.statcounter.com/9021069/0/fdde5482/1/" height="1" width="1"></noscript>
<!-- End MarketBeat News Network StatCounter Code -->

<!-- Start of StatCounter Code for WKRB -->
<script type="text/javascript">
var sc_project=11650630; 
var sc_invisible=1; 
var sc_security="2798fb99"; 
var sc_https=1; 
var scJsHost = (("https:" == document.location.protocol) ? "https://secure." : "http://www.");
</script>
<script type="text/javascript" src="https://www.statcounter.com/counter/counter.js"></script><noscript><img class="statcounter" src="//c.statcounter.com/11650630/0/2798fb99/1/" alt="Web Analytics"></a></noscript>
<!-- End of StatCounter Code for WKRB -->
	


<!-- Begin Social Sharing -->
		<div style="top:25%;left:0;position:fixed;width:50px;z-index:20;box-sizing:content-box;" class="mobile-hide">
	<div style="background-color:#305891;border:0;width:30px;height:30px;padding:9px;box-sizing:content-box;"><a href="https://www.facebook.com/sharer/sharer.php?u=https://www.wkrb13.com/2020/11/09/micromines-tops-24-hour-trading-volume-of-57-00-micro.html" target="_blank"><img src="/images/social-fb.png" style="margin:0;padding:0;" alt="share news on Facebook"></a></div>
	<div style="background-color:#2CA8D2;border:0;width:30px;height:30px;padding:9px;box-sizing:content-box;"><a href="https://twitter.com/intent/tweet?text=Micromines Tops 24-Hour Trading Volume of $57.00 $MICRO https://www.wkrb13.com/2020/11/09/micromines-tops-24-hour-trading-volume-of-57-00-micro.html" target="_blank"><img src="/images/social-tw.png" style="margin:0;padding:0;" alt="tweet this investment news"></a></div>
	<div style="background-color:#007BB6;border:0;width:30px;height:30px;padding:9px;box-sizing:content-box;"><a href="https://www.linkedin.com/cws/share?mini=true&url=https://www.wkrb13.com/2020/11/09/micromines-tops-24-hour-trading-volume-of-57-00-micro.html" target="_blank"><img src="/images/social-in.png" style="margin:0;padding:0;" alt="share on linkedin"></a></div>
	<div style="background-color:#89120a;border:0;width:30px;height:30px;padding:9px;box-sizing:content-box;"><a href="https://api.stocktwits.com/widgets/share?via=AnalystRatingsNetwork&body=Micromines Tops 24-Hour Trading Volume of $57.00 $MICRO https://www.wkrb13.com/2020/11/09/micromines-tops-24-hour-trading-volume-of-57-00-micro.html" target="_blank"><img src="/images/social-st.png" style="margin:0;padding:0;box-sizing:content-box;" alt="share on StockTwits"></a></div>
	<div style="background-color:#FF1A00;border:0;width:30px;height:30px;padding:9px;box-sizing:content-box;"><a href="https://www.reddit.com/submit?url=https://www.wkrb13.com/2020/11/09/micromines-tops-24-hour-trading-volume-of-57-00-micro.html&title=Micromines Tops 24-Hour Trading Volume of $57.00 (MICRO)" target="_blank"><img src="/images/social-reddit.png" style="margin:0;padding:0;" alt="share on reddit"></a></div>
	</div>
	<!-- End Social Sharing -->

<!-- Begin Internal Tracking Pixel 2 -->
<script type='text/javascript'>document.write('<img src="https://www.american' + 'consumernews.net/scripts/viewcount.ashx?ArticleHistoryID=64865351&PostDate=2020-11-9&type=x&id=1530473&domain=www.wkrb13.com&referrer=' + encodeURIComponent(document.referrer) + '" />');</script>
<!-- End Internal Tracking Pixel 2-->

<!-- Begin comScore Tag -->
<script>
  var _comscore = _comscore || [];
  _comscore.push({ c1: "2", c2: "16807273" });
  (function() {
    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
    s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";
    el.parentNode.insertBefore(s, el);
  })();
</script>
<noscript>
  <img src="http://b.scorecardresearch.com/p?c1=2&c2=16807273&cv=2.0&cj=1" />
</noscript>
<!-- End comScore Tag -->

<!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-3019647-43"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-3019647-43');
</script>



</div>

	</body>
</html>