<!doctype html>
<html lang="en">
<head>
<meta name="distribution" content="global" />
<meta name="robots" content="follow, all" />
<meta content="text/html; charset=UTF-8" http-equiv="Content-Type" />

<meta name="theme-color" content="#081c59"/>
 

<meta name="viewport" content="width=device-width, initial-scale=1.0">

<!-- Escape from Frames -->
<script type="text/javascript">if(self==top){document.documentElement.style.display="block"}else{top.location=self.location}</script>

<link rel="preconnect" href="https://fonts.gstatic.com">
<link href="https://fonts.googleapis.com/css2?family=Roboto&display=swap" rel="stylesheet">


<style>

:root {
  --header-background: #ffffff;
  --button-background: #081c59;
  --button-background-2: #081c59;
  --button-hover-background: #0e30a0;
  --button-hover-background-2: #0e30a0;
  --button-text-color: #fff;
  --link-color: #0e309e;
  --link-hover-color: #0e309e;
  --link-text-decoration: none; /* text field */
  --hover-link-text-decoration: underline; /* text field */
  --menu-background: #eaeaea;
  --menu-background-2: #eaeaea;
  --menu-text-color: #081c59;
  --menu-active-hover-background: #081c59;
  --menu-active-hover-text-color: #fff;
  --top-menu-background: #f2ac07;
  --top-menu-link-color: #081c59;
  --top-menu-link-hover-color: #0e309e;
  --accent-color: #0e309e;
  --accent-color-2: #081c59;
  --sidebar-h3-color: #081c59;
  --light-gray-color:#eaeaea;
  --light-gray-link-color:#eaeaea;
  --light-gray-link-hover-color:#eaeaea;
  --list-item-bottom-border: solid 1px #f2ac07;
  --border-radius: 0;
  --border-radius-small-items: 0;
  --H1-font: bold 2em/1.3 'Roboto',sans-serif;
  --H2-font:  bold 1.3em/1.3 'Roboto',sans-serif;
  --H3-font:  bold uppercase 1.1em/1.3 'Roboto',sans-serif;
  --body-font: 15px 'Roboto',sans-serif;
  --menu-font: 1em 'Roboto', sans-serif;
  --box-shadow: 0px 0px 3px 0px #f2ac07; 
  --body-background: #061442;
  --body-background-2: #0e30a1;
  --body-font-color: #555555;

}


body {
	font: var(--body-font);
    background: var(--body-background);
	color: var(--body-font-color);
	 
		
	background: -moz-linear-gradient(top, var(--body-background) 0%, var(--body-background-2) 100%);
    background: -webkit-gradient(left top,left bottom,color-stop(0%, var(--body-background)),color-stop(100%, var(--body-background-2)));
    background: -webkit-linear-gradient(top, var(--body-background) 0%, var(--body-background-2) 100%);
    background: -o-linear-gradient(top, var(--body-background) 0%, var(--body-background-2) 100%);
    background: -ms-linear-gradient(top, var(--body-background) 0%, var(--body-background-2) 100%);
    background: linear-gradient(to bottom, var(--body-background) 0%, var(--body-background-2) 100%);
		
    background-attachment: fixed;
    background-size: cover;
}

</style>
<link rel="stylesheet" href="https://www.wkrb13.com/wp-content/themes/responsalambre/style.css?v=2021abcdefghij" type="text/css" media="screen">
	
<link href="https://www.wkrb13.com/feed" rel="alternate" title="WKRB News RSS Feed" type="application/rss+xml" />
<link href="https://www.wkrb13.com/feed/atom" rel="alternate" title="WKRB News Atom Feed" type="application/atom+xml" />
<link href="https://www.wkrb13.com/xmlrpc.php" rel="pingback" />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://www.wkrb13.com/wp-includes/css/dist/block-library/style.min.css?ver=5.5.9' type='text/css' media='all' />
<link rel="https://api.w.org/" href="https://www.wkrb13.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.wkrb13.com/wp-json/wp/v2/posts/4330802" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.wkrb13.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.wkrb13.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='AGF Investments Inc. Trims Holdings in JPMorgan Chase &#038; Co. (NYSE:JPM)' href='https://www.wkrb13.com/2022/04/10/agf-investments-inc-trims-holdings-in-jpmorgan-chase-co-nysejpm.html' />
<link rel='next' title='The Allstate Co. (NYSE:ALL) Shares Sold by RFG Advisory LLC' href='https://www.wkrb13.com/2022/04/10/the-allstate-co-nyseall-shares-sold-by-rfg-advisory-llc.html' />
<meta name="generator" content="WordPress 5.5.9" />
<link rel="canonical" href="https://www.wkrb13.com/2022/04/10/rfg-advisory-llc-cuts-stock-holdings-in-w-p-carey-inc-nysewpc.html" />
<link rel='shortlink' href='https://www.wkrb13.com/?p=4330802' />
<link rel="alternate" type="application/json+oembed" href="https://www.wkrb13.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.wkrb13.com%2F2022%2F04%2F10%2Frfg-advisory-llc-cuts-stock-holdings-in-w-p-carey-inc-nysewpc.html" />
<link rel="alternate" type="text/xml+oembed" href="https://www.wkrb13.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.wkrb13.com%2F2022%2F04%2F10%2Frfg-advisory-llc-cuts-stock-holdings-in-w-p-carey-inc-nysewpc.html&#038;format=xml" />
<link rel="manifest" href="https://www.wkrb13.com/manifest.json"><link rel="amphtml" href="https://www.wkrb13.com/2022/04/10/rfg-advisory-llc-cuts-stock-holdings-in-w-p-carey-inc-nysewpc.html/amp" /><link rel="icon" href="https://www.wkrb13.com/wp-content/uploads/2018/03/wkrb13-03-150x150.png" sizes="32x32" />
<link rel="icon" href="https://www.wkrb13.com/wp-content/uploads/2018/03/wkrb13-03.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.wkrb13.com/wp-content/uploads/2018/03/wkrb13-03.png" />
<meta name="msapplication-TileImage" content="https://www.wkrb13.com/wp-content/uploads/2018/03/wkrb13-03.png" />

<!-- Start Meta Data -->
<title>RFG Advisory LLC Cuts Stock Holdings in W. P. Carey Inc. (NYSE:WPC) - WKRB News</title>
<meta name="description" content="Read RFG Advisory LLC Cuts Stock Holdings in W. P. Carey Inc. (NYSE:WPC) at WKRB News"/>
<meta name="distribution" content="global" />
<meta name="robots" content="follow, all" />
<meta name="description" content="RFG Advisory LLC trimmed its holdings in shares of W. P. Carey Inc. (NYSE:WPC &#8211; Get Rating) by 35.2% in the 4th quarter, HoldingsChannel.com reports. The institutional investor owned 4,859 shares of the real estate investment trust&#8217;s stock after selling 2,637 shares during the period. RFG Advisory LLC&#8217;s holdings in W. P. Carey were worth [&hellip;]" />
<meta name="author" content="Lisa Pomrenke">
<meta name="news_keywords" content="W. P. Carey,NYSE:WPC,WPC,Finance,SEC Filings,13F,Hedge Fund Holdings,Institutional Investor Holdings" />
<meta name="keywords" content="W. P. Carey,NYSE:WPC,WPC,Finance,SEC Filings,13F,Hedge Fund Holdings,Institutional Investor Holdings" />
<meta name="ticker" content="NYSE:WPC" />
<meta name="contentType" content="article">

<!-- Twitter Card Data -->
<meta name="twitter:card" content="summary"/>
<meta name="twitter:site" content="@MarketBeatCom" />
<meta name="twitter:title" content="RFG Advisory LLC Cuts Stock Holdings in W. P. Carey Inc. (NYSE:WPC)"/>
<meta name="twitter:description" content="RFG Advisory LLC trimmed its holdings in shares of W. P. Carey Inc. (NYSE:WPC &#8211; Get Rating) by 35.2% in the 4th quarter, HoldingsChannel.com reports. The institutional investor owned 4,859 shares of the real estate investment trust&#8217;s stock after selling 2,637 shares during the period. RFG Advisory LLC&#8217;s holdings in W. P. Carey were worth [&hellip;]" />
<meta name="twitter:creator" content="@RatingsNetwork" />
<meta name="twitter:image" content="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/w-p-carey-logo.jpg&amp;w=240&amp;h=240&amp;zc=2" />

<!-- Open Graph Data -->
<meta property="og:title" content="RFG Advisory LLC Cuts Stock Holdings in W. P. Carey Inc. (NYSE:WPC)" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.wkrb13.com/2022/04/10/rfg-advisory-llc-cuts-stock-holdings-in-w-p-carey-inc-nysewpc.html" />
<meta property="og:image" content="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/w-p-carey-logo.jpg&amp;w=240&amp;h=240&amp;zc=2" />
<meta property="og:image:width" content="240" />
<meta property="og:image:height" content="240" />
<meta property="og:description" content="RFG Advisory LLC trimmed its holdings in shares of W. P. Carey Inc. (NYSE:WPC &#8211; Get Rating) by 35.2% in the 4th quarter, HoldingsChannel.com reports. The institutional investor owned 4,859 shares of the real estate investment trust&#8217;s stock after selling 2,637 shares during the period. RFG Advisory LLC&#8217;s holdings in W. P. Carey were worth [&hellip;]" />
<meta property="og:site_name" content="WKRB News" />
<meta property="og:locale" content="en_US" />

<!-- OG Article Template -->
<meta property="article:published_time" content="2022-04-10T15:24:48+0000" />
<meta property="article:modified_time" content="2022-04-10T15:24:48+0000" />
<meta property="article:tag" content="NYSE:WPC" />
<meta property="article:tag" content="W. P. Carey,NYSE:WPC,WPC,Finance,SEC Filings,13F,Hedge Fund Holdings,Institutional Investor Holdings" />
<meta property="article:section" content="Markets" />

<!-- Google meta is in the body-->

<!-- End Meta Data -->

	
<script type='text/javascript'>var PopupAdChannel=''; </script>

  <link rel="manifest" href="/manifest.json">
  <script src="https://cdn.onesignal.com/sdks/OneSignalSDK.js"></script>
  <script>
  	function registerUserChange(action) {
		OneSignal.getUserId( function(userId) {
			OneSignalIdString = userId;
			var Domain = 'wkrb13.com';
			var url = "https://www.marketbeat.com/scripts/OneSignalTracking.ashx?OneSignalID=" + OneSignalIdString + "&domain=" + Domain + "&action=" + action;
			var xhr = new XMLHttpRequest();
			xhr.open('GET', url);
			xhr.onload = function () {
				if (xhr.status !== 200) {
					console.log('GET failed.  Returned status of ' + xhr.status);
				}
			};
			xhr.send();
		});
	}
    var OneSignal = window.OneSignal || [];
    OneSignal.push(["init", {
      appId: "27539f7d-08b9-4089-9eac-48d0d5b908a5",
      safari_web_id: 'web.onesignal.auto.54cd441e-7f12-4aed-9845-f98eb5c10ecb', 
      autoRegister: false,
      notifyButton: {
        enable: false /* Set to false to hide */
      },
 welcomeNotification: {
        "title": "Join Wall Street's Brightest Minds.",
        "message": "Receive research in your inbox from top analysts, before the market opens. Click here to learn how.",
         "url": "https://www.marketbeat.com/subscribe/subscribe.aspx?ReferralType=OneSignalThankYou&ProductCode=1997t"
    }
    },
		OneSignal.once('subscriptionChange', function (isSubscribed) {
			if(isSubscribed) {
				registerUserChange("subscribe");
			}
			else {
				registerUserChange("unsubscribe");
			}
			
		  })
	]);
if((navigator.userAgent.toLowerCase().indexOf('firefox') > -1)||((navigator.userAgent.toLowerCase().indexOf('safari') > -1)&&(!(navigator.userAgent.toLowerCase().indexOf('chrome') > -1)))){
		OneSignal.showSlidedownPrompt();
	} else {
		OneSignal.showNativePrompt();		
	}  </script>



<script type="text/javascript">var vbnfgha = '211626'; var ertdfga = '13739-bup-ac'; var qhyuioa = '53938'; var AdClientID = qhyuioa + vbnfgha + ertdfga; AdClientID = AdClientID.split("").reverse().join("");</script>


	
	<script type="text/javascript" src="https://www.marketbeat.com/Scripts/lowerrightad.js?v=2021"></script>
	
	<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({
          google_ad_client: AdClientID,
          enable_page_level_ads: false
     });
</script>

</head>
<body>
<div id="wrap">
<script type="text/javascript" src="https://www.marketbeat.com/scripts/modal/modernpopup.js?v=60"></script>
	
<!-- Start MarketBeat Modern Popup -->
<link rel="stylesheet" type="text/css" media="all" href="https://www.marketbeat.com/scripts/modal/modernpopup.css?v=12"/>
	
	
	<script type="text/javascript">LoadPopupRatings('ModernMarketsPopup-WKRB News', 'wkrb13.com', 'NYSE:WPC', 'W. P. Carey', 'https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?w=175&zc=1&src=https://www.marketbeat.com/logos/w-p-carey-logo.jpg');</script>
	<!-- End MarketBeat Modern Popup -->
	
<a class="skip-link scroll" href="#main">Skip to main content</a>
<header>
	<div class="width-limiter background-light top-menu-bar">
		<div style='color:#222;text-align:right;'>
			<nav class="navigation top-menu" aria-label="Utility Links"><ul id="menu-top-bar" class="menu"><li id="menu-item-19" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-19"><a href="https://wkrb13.com">Home</a></li>
<li id="menu-item-18" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-18"><a href="https://www.wkrb13.com/about">About</a></li>
<li id="menu-item-17" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-17"><a href="https://www.wkrb13.com/daily-email-updates-basic">Daily Email Updates</a></li>
<li id="menu-item-47" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-47"><a href="https://www.wkrb13.com/privacy-policy">Privacy Policy</a></li>
</ul></nav>		</div>
   </div>
<!-- start for mobile menu -->
<div class="width-limiter top-mobile-menu" id='mobile-logo-bar'>
	 <label for="nav-trigger" style="display:inline-block; width:30vw; color:#12424d;vertical-align:middle;">&#9776;</label> 
	 <a style='vertical-align:middle;width:33vw;display:inline-block;text-align:center;padding:5px;' href="https://www.wkrb13.com"><img style='width:120px' src="https://www.wkrb13.com/wp-content/uploads/2021/05/wkrb-logo-01.png" alt="WKRB News logo" width="844" height="336"></a>
	</div>
	<div class="width-limiter" style="min-height: 5px;" id='mobile-menu-bar'>
		
                	<input type="checkbox" id="nav-trigger" class="navOpen" />
                
                	<div class="mobile-nav nice-scroll">
                		
							
                			
                			<nav class="mobile-menu" aria-label="Category Mobile Menu"><ul id="menu-category-menu" class="menu"><li id="menu-item-31" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-31"><a href="https://www.wkrb13.com/category/markets">Markets</a></li>
<li id="menu-item-60" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-60"><a href="https://www.wkrb13.com/category/markets/analyst-articles-us">Ratings</a></li>
<li id="menu-item-54" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-54"><a href="https://www.wkrb13.com/category/markets/dividend-articles">Dividends</a></li>
<li id="menu-item-55" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-55"><a href="https://www.wkrb13.com/category/markets/earnings-articles-single">Earnings</a></li>
<li id="menu-item-56" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56"><a href="https://www.wkrb13.com/category/markets/insider-trades">Insider Trades</a></li>
<li id="menu-item-24" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24"><a href="https://www.wkrb13.com/category/markets/cryptocurrencies">Cryptocurrencies</a></li>
</ul></nav>                			<nav class="mobile-menu" aria-label="Utility Mobile Menu"><ul id="menu-top-bar-1" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-19"><a href="https://wkrb13.com">Home</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-18"><a href="https://www.wkrb13.com/about">About</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-17"><a href="https://www.wkrb13.com/daily-email-updates-basic">Daily Email Updates</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-47"><a href="https://www.wkrb13.com/privacy-policy">Privacy Policy</a></li>
</ul></nav>                			
                			<form class="mobile-search" id="mobileSearchForm" action="https://www.wkrb13.com/" method="get">
                				<div class="search">
                					<input id="s" style='margin-left:0;' class="searchinput" aria-label="Search Keywords" name="s" onclick="this.value='';" type="text" />
                					<input class="searchsubmit" type="submit" value="SEARCH" />
                				</div>
                			</form>
						<div>
	
						</div>
                	</div>
		
	</div>
<!-- end for mobile menu -->
	<div class="width-limiter add-padding flex-container"><!-- start: width-limiter with logo and space for alternate header unit -->
		
		<a class="logo-link flex-logo" id="header-logo-link" href="https://www.wkrb13.com" title="WKRB News"><img id="logo" src="https://www.wkrb13.com/wp-content/uploads/2021/05/wkrb-logo-01.png" alt="WKRB News logo" width="844" height="336"></a>

<!-- Begin Header Unit -->
<div id="AlternateHeaderUnit" class="flex-header-ad">
	<iframe class="large-show" src="https://marketbeat.com/scripts/HeaderAdNewsSites.ashx" width="728" height="110" frameborder="no" scrolling="no" style="width: 100%;overflow:hidden;" title="Ad"></iframe>
	<iframe class="small-show" src="https://marketbeat.com/scripts/SidebarAdNewsSites.ashx" width="336" height="280" frameborder="no"scrolling="no" style="overflow:hidden;margin:0 auto;" title="Ad"></iframe>
</div> 

<!-- End Header Unit-->
	</div> <!-- end: width-limiter with logo and space for alternate header unit -->
	<div id="menu">
		<div class="width-limiter flex-container" id="nav-main">
			
			<!-- start main category menu -->
			
			<div class="flex-nav">
			   
			  



			<nav class="navigation" aria-label="Main Menu"><ul id="menu-category-menu-1" class="menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-31"><a href="https://www.wkrb13.com/category/markets">Markets</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-60"><a href="https://www.wkrb13.com/category/markets/analyst-articles-us">Ratings</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-54"><a href="https://www.wkrb13.com/category/markets/dividend-articles">Dividends</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-55"><a href="https://www.wkrb13.com/category/markets/earnings-articles-single">Earnings</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56"><a href="https://www.wkrb13.com/category/markets/insider-trades">Insider Trades</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24"><a href="https://www.wkrb13.com/category/markets/cryptocurrencies">Cryptocurrencies</a></li>
</ul></nav>			
			</div>
				<form class="flex-search" id="searchform" action="https://www.wkrb13.com/" method="get">
					<div class="search">
						<input id="s-main" class="searchinput" name="s" aria-label="Search Keywords" onclick="this.value='';" type="text" />
						<input class="searchsubmit" type="submit" value="SEARCH" />
					</div>
					
				</form><!-- end: searchform -->
		</div> <!-- end: width-limiter for menu -->
	</div> <!-- end: menu -->
</header> <!-- end: header -->
	<div class="width-limiter main-content flex-container">
		

		<main class="flex-main" id="main">
			 <article itemscope itemtype="http://schema.org/NewsArticle">
				
				<link itemprop="mainEntityOfPage" href="https://www.wkrb13.com/2022/04/10/rfg-advisory-llc-cuts-stock-holdings-in-w-p-carey-inc-nysewpc.html" />
				<h1 itemprop="headline" class="page-title">RFG Advisory LLC Cuts Stock Holdings in W. P. Carey Inc. (NYSE:WPC)</h1>

				<p class="postmeta">
					Posted by <span itemprop="author" itemscope itemtype="https://schema.org/Person"><span itemprop="name"><a href="https://www.wkrb13.com/author/lisap" title="Posts by Lisa Pomrenke" rel="author">Lisa Pomrenke</a></span></span> on <span itemprop="datePublished dateModified" content="2022-04-10T15:24:48+0000">Apr 10th, 2022</span>
				</p><!--end .postmeta-->

				<div class="social-shares">
					
					
		 
			
					<a title="Share on Twitter" rel="noopener nofollow" target="_blank" style="background: #1DA1F2;" href="https://twitter.com/intent/tweet?original_referer=https%3A%2F%2Fwww.wkrb13.com&ref_src=twsrc%5Etfw&text=RFG%20Advisory%20LLC%20Cuts%20Stock%20Holdings%20in%20W.%20P.%20Carey%20Inc.%20%28NYSE%3AWPC%29%20%24WPC&tw_p=tweetbutton&url=https%3A%2F%2Fwww.wkrb13.com%2F2022%2F04%2F10%2Frfg-advisory-llc-cuts-stock-holdings-in-w-p-carey-inc-nysewpc.html&via=WKRBnews"><span class="share-button"><svg style="fill: #fff;" xmlns="http://www.w3.org/2000/svg" width="24" height="24" viewBox="0 0 24 24"><path d="M24 4.557c-.883.392-1.832.656-2.828.775 1.017-.609 1.798-1.574 2.165-2.724-.951.564-2.005.974-3.127 1.195-.897-.957-2.178-1.555-3.594-1.555-3.179 0-5.515 2.966-4.797 6.045-4.091-.205-7.719-2.165-10.148-5.144-1.29 2.213-.669 5.108 1.523 6.574-.806-.026-1.566-.247-2.229-.616-.054 2.281 1.581 4.415 3.949 4.89-.693.188-1.452.232-2.224.084.626 1.956 2.444 3.379 4.6 3.419-2.07 1.623-4.678 2.348-7.29 2.04 2.179 1.397 4.768 2.212 7.548 2.212 9.142 0 14.307-7.721 13.995-14.646.962-.695 1.797-1.562 2.457-2.549z"/></svg></span><span class="share-title">Share on Twitter</span></a>
					
					
	<a title="Share on Facebook" rel="noopener nofollow" target="_blank" style="background:#4267B2;" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.wkrb13.com%2F2022%2F04%2F10%2Frfg-advisory-llc-cuts-stock-holdings-in-w-p-carey-inc-nysewpc.html"><span class="share-button"><svg style="fill: #fff;" xmlns="http://www.w3.org/2000/svg" width="24" height="24" viewBox="0 0 24 24"><path d="M9 8h-3v4h3v12h5v-12h3.642l.358-4h-4v-1.667c0-.955.192-1.333 1.115-1.333h2.885v-5h-3.808c-3.596 0-5.192 1.583-5.192 4.615v3.385z"/></svg></span><span class="share-title">Share on Facebook</span></a>
				 
<a title="Share on LinkedIn" rel="noopener nofollow" target="_blank" style="background: #0067b1;" href="https://www.linkedin.com/shareArticle?mini=true&url=https%3A%2F%2Fwww.wkrb13.com%2F2022%2F04%2F10%2Frfg-advisory-llc-cuts-stock-holdings-in-w-p-carey-inc-nysewpc.html"><span class="share-button"><svg style="fill: #fff;" xmlns="http://www.w3.org/2000/svg" width="24" height="24" viewBox="0 0 24 24"><path d="M4.98 3.5c0 1.381-1.11 2.5-2.48 2.5s-2.48-1.119-2.48-2.5c0-1.38 1.11-2.5 2.48-2.5s2.48 1.12 2.48 2.5zm.02 4.5h-5v16h5v-16zm7.982 0h-4.968v16h4.969v-8.399c0-4.67 6.029-5.052 6.029 0v8.399h4.988v-10.131c0-7.88-8.922-7.593-11.018-3.714v-2.155z"/></svg></span><span class="share-title">Share on LinkedIn</span></a>
				 
				<a title="Share on Stocktwits" rel="noopener nofollow" style="background:#228dff;" href="https://api.stocktwits.com/widgets/share?via=MarketBeat&amp;body=RFG%20Advisory%20LLC%20Cuts%20Stock%20Holdings%20in%20W.%20P.%20Carey%20Inc.%20%28NYSE%3AWPC%29%20%24WPC" title="Share on StockTwits"><span class="share-button"><svg style="fill:#fff;" version="1.1" id="Layer_1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink"  width="24" height="24" viewBox="0 0 30 30" style="enable-background:new 0 0 30 30;" xml:space="preserve"><polygon class="st0" points="21.98,17.75 21.98,13.29 14.54,9.67 21.98,6.19 21.98,1.84 9.02,8.45 9.02,11.12 "/><polygon class="st0" points="9.07,13.19 9.07,17.65 16.49,21.27 9.07,24.76 9.07,29.1 21.98,22.49 21.98,19.82 "/></svg></span><span class="share-title">Share on Stocktwits</span></a>
					
</div>
<div style="clear:both"></div>
				<!--sse-->
				<div class="entry" itemprop="articleBody"> 
				<!-- start main text -->
				<iframe src="https://www.marketbeat.com/scripts/TextAdNewsSites.ashx?color=0e309e" frameborder=no width="100%" height="35" scrolling="no" title="Advertisement"></iframe>

					<p><img height="150" width="250" src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?w=250&h=150&zc=2&src=https://www.marketbeat.com/logos/w-p-carey-logo.jpg" alt="W. P. Carey logo" title="W. P. Carey" class="companylogo" />RFG Advisory LLC trimmed its holdings in shares of  W. P. Carey Inc. (<a href='https://www.marketbeat.com/stocks/NYSE/WPC/'>NYSE:WPC</a> &#8211; <a style='font-weight:normal;text-decoration:italic;color:green' href='https://report.stocknews.com/sign-up/ticker/?ticker=WPC&#038;lead_source=marketbeat_snra&#038;utm_source=marketbeat_snra&#038;utm_medium=article&#038;utm_campaign=ticker&#038;utm_term=WPC&#038;utm_content=text_link'>Get Rating</a>) by 35.2% in the 4th quarter, <a href='http://www.holdingschannel.com/'>HoldingsChannel.com</a> reports. The institutional investor  owned 4,859 shares of the real estate investment trust&#8217;s stock after selling 2,637 shares during the period. RFG Advisory LLC&#8217;s holdings in W. P. Carey were worth $399,000 at the end of the most recent quarter. </p>
<p>Other hedge funds and other institutional investors have also bought and sold shares of the company. D.A. Davidson &#038; CO. boosted its holdings in shares of  W. P. Carey by 1.2% during the fourth quarter. D.A. Davidson &#038; CO. now owns 11,094 shares of the real estate investment trust&#8217;s stock worth $910,000 after purchasing an additional 130 shares during the period.  Richard P Slaughter Associates Inc boosted its holdings in shares of  W. P. Carey by 1.0% during the fourth quarter. Richard P Slaughter Associates Inc now owns 15,471 shares of the real estate investment trust&#8217;s stock worth $1,269,000 after purchasing an additional 147 shares during the period.  Clal Insurance Enterprises Holdings Ltd boosted its holdings in shares of  W. P. Carey by 8.6% during the third quarter. Clal Insurance Enterprises Holdings Ltd now owns 1,940 shares of the real estate investment trust&#8217;s stock worth $144,000 after purchasing an additional 153 shares during the period.  Keudell Morrison Wealth Management boosted its holdings in shares of  W. P. Carey by 5.2% during the third quarter. Keudell Morrison Wealth Management now owns 3,122 shares of the real estate investment trust&#8217;s stock worth $228,000 after purchasing an additional 153 shares during the period.  Finally, Gilbert &#038; Cook Inc. boosted its holdings in shares of  W. P. Carey by 3.9% during the fourth quarter. Gilbert &#038; Cook Inc. now owns 4,318 shares of the real estate investment trust&#8217;s stock worth $354,000 after purchasing an additional 164 shares during the period. Institutional investors and hedge funds own  59.45% of the company&#8217;s stock. </p>
<form method="get" action="https://www.marketbeat.com/newsletter/default.aspx" style="border-bottom-width: 1px; border-color: #D2D2D2; border-style: solid; border-top-width: 1px; margin-bottom: 24px; margin-top: 12px; padding: 12px 0;border-right:none;border-left:none;clear:both;">
    <input type="hidden" id="Hidden1" name="RegistrationCode" value="InPost-WKRB News"  />
    <input type="hidden" id="Hidden2" name="RegisterTicker" value="NYSE:WPC" />    <label for="InPostRegistrationEmail">Get <b>W. P. Carey</b> alerts:</label>
    <div style="display:inline-block;"><input id="InPostRegistrationEmail" name="RegisterEmail" type="email" placeholder="Enter Your Email Address" style="border: 1px solid #D2D2D2;font-size: 0.9em;line-height: 1em;margin: 0;min-width: 200px; padding: 4px;" /><input type="submit" name="submit" class="button" onclick="return CheckEmail('InPostRegistrationEmail','ShowSuggestionInPost');" value="Submit" style="-webkit-appearance: none;-moz-appearance: none;appearance: none;font-size: 0.9em;font-weight: 700;line-height: 1em;padding: 6px 18px"></div>
</form>
<div id="ShowSuggestionInPost"></div>


<p>A number of research firms have recently weighed in on WPC. <a style='font-weight:bold' href='https://www.zacks.com/registration/premium/login/?adid=AMERBMN_CONTENT_ZER'>Zacks Investment Research</a> upgraded shares of W. P. Carey from a &#8220;hold&#8221; rating to a &#8220;buy&#8221; rating and set a $89.00 target price for the company in a report on Wednesday, March 16th. <a style='font-weight:bold' href='https://report.stocknews.com/sign-up/ticker/?ticker=WPC&#038;lead_source=marketbeat_snra&#038;utm_source=marketbeat_snra&#038;utm_medium=article&#038;utm_campaign=ticker&#038;utm_term=WPC&#038;utm_content=text_link'>StockNews.com</a> raised shares of W. P. Carey from a &#8220;hold&#8221; rating to a &#8220;buy&#8221; rating in a research note on Tuesday, April 5th. Finally, Bank of America raised shares of W. P. Carey from an &#8220;underperform&#8221; rating to a &#8220;neutral&#8221; rating in a research note on Thursday, January 20th. One equities research analyst  has rated the stock with a hold rating and seven have issued  a buy rating to the stock. Based on data from MarketBeat, W. P. Carey currently has an average rating of &#8220;Buy&#8221; and an average target price of $87.33.</p>
<p>
		  <div class="in-article-ad" class="width:340px;">
<iframe src="https://marketbeat.com/scripts/336x280AdNewsSites.ashx" width="336" height="280" frameborder="no" title="Offer"></iframe>
</div>


                 Shares of <a href='https://www.marketbeat.com/stocks/NYSE/WPC/sec-filings/' target='_blank' rel="noopener noreferrer">NYSE WPC</a> traded up $1.03 on Friday, reaching $82.69. 845,345 shares of the company&#8217;s stock traded hands, compared to its average volume of 930,922. W. P. Carey Inc. has a 12 month low of $70.15 and a 12 month high of $83.60. The business&#8217;s 50 day simple moving average is $78.67 and its two-hundred day simple moving average is $78.25. The company has a market cap of $15.84 billion, a price-to-earnings ratio of 37.08 and a beta of 0.75. The company has a quick ratio of 0.17, a current ratio of 0.17 and a debt-to-equity ratio of 0.84. </p>
<p>The firm also recently announced a quarterly dividend, which will be paid on Thursday, April 14th. Shareholders of record on Thursday, March 31st will be paid a dividend of $1.057 per share. This is an increase from W. P. Carey&#8217;s previous quarterly dividend of $1.06. The ex-dividend date of this dividend is Wednesday, March 30th. This represents a $4.23 dividend on an annualized basis and a dividend yield of 5.11%. W. P. Carey&#8217;s dividend payout ratio (DPR) is currently 189.69%. </p>
<p><strong>W. P. Carey Company Profile</strong> (<a style='font-weight:normal;text-decoration:italic;color:green' href='https://report.stocknews.com/sign-up/ticker/?ticker=WPC&#038;lead_source=marketbeat_snra&#038;utm_source=marketbeat_snra&#038;utm_medium=article&#038;utm_campaign=ticker&#038;utm_term=WPC&#038;utm_content=text_link'>Get Rating</a>)</p>
<p>W. P. Carey ranks among the largest net lease REITs with an enterprise value of approximately $18 billion and a diversified portfolio of operationally-critical commercial real estate that includes 1,215 net lease properties covering approximately 142 million square feet as of September 30, 2020. For nearly five decades, the company has invested in high-quality single-tenant industrial, warehouse, office, retail and self-storage properties subject to long-term net leases with built-in rent escalators.</p>
<p><strong>Featured Stories</strong></p>
<ul>
<li><a href='https://report.stocknews.com/sign-up/ticker/?ticker=WPC&#038;lead_source=marketbeat_snra&#038;utm_source=marketbeat_snra&#038;utm_medium=article&#038;utm_campaign=ticker&#038;utm_term=WPC&#038;utm_content=text_link' target='_blank' rel="noopener noreferrer">Get a free copy of the StockNews.com research report on W. P. Carey (WPC)</a></li>
<li><a href='https://www.marketbeat.com/originals/3-recession-proof-stocks-to-buy-now/' target='_blank' rel="noopener noreferrer">3 Recession-Proof Stocks to Buy Now</a></li>
<li><a href='https://www.marketbeat.com/originals/marketbeat-week-in-review-4-4-4-8/' target='_blank' rel="noopener noreferrer">MarketBeat: Week in Review 4/4 – 4/8</a></li>
<li><a href='https://www.marketbeat.com/originals/3-best-life-sciences-stocks-to-buy-now/' target='_blank' rel="noopener noreferrer">3 Best Life Sciences Stocks to Buy Now</a></li>
<li><a href='https://www.insidertrades.com/education/the-institutional-insiders-are-buying-wd-40-company/' target='_blank' rel="noopener noreferrer">The Institutional Insiders Are Buying WD-40 Company</a></li>
<li><a href='https://www.marketbeat.com/originals/whats-behind-the-latest-surge-in-gamestop-nyse-gme/' target='_blank' rel="noopener noreferrer">What’s Behind The Latest Surge In GameStop (NYSE: GME)?</a></li>
</ul>
<p><!--ViewCount:ArticleHistoryID=87493503&PostDate=2022-4-10&type=f&id=11472886--></p>
<p><strong>Want to see what other hedge funds are holding WPC?</strong> <a href='https://www.holdingschannel.com/hedge-funds/holding-wpc/'>Visit HoldingsChannel.com</a> to get the latest 13F filings and insider trades for W. P. Carey Inc. (<a href='https://www.marketbeat.com/stocks/NYSE/WPC/'>NYSE:WPC</a> &#8211; <a style='font-weight:normal;text-decoration:italic;color:green' href='https://report.stocknews.com/sign-up/ticker/?ticker=WPC&#038;lead_source=marketbeat_snra&#038;utm_source=marketbeat_snra&#038;utm_medium=article&#038;utm_campaign=ticker&#038;utm_term=WPC&#038;utm_content=text_link'>Get Rating</a>).</p>
<p style='text-align:center'><img src='https://www.marketbeat.com/scripts/SECFilingChart.ashx?Prefix=NYSE&#038;Symbol=WPC' alt='Institutional Ownership by Quarter for W. P. Carey (NYSE:WPC)' width='650' height='350'/></p>
<p><!--Keyword: W. P. Carey,NYSE:WPC,WPC,Finance,SEC Filings,13F,Hedge Fund Holdings,Institutional Investor Holdings--><!--Ratings:4,6,NYSE:WPC--></p>

			 	<!-- end inline unit -->
				<!-- end main text -->
				<!-- Invalidate Article -->
					 
				<!-- End Invalidate -->

<!--Begin Footer Opt-In-->
<p style="clear:both"><strong>Receive News &amp; Ratings for W. P. Carey Daily</strong> - Enter your email address below to receive a concise daily summary of the latest news and analysts' ratings for W. P. Carey and related companies with <a href="/daily-email-updates-basic/?symbol=NYSE:WPC&c=W.+P.+Carey" rel="nofollow" style="text-decoration:underline;font-weight:bold">MarketBeat.com's FREE daily email newsletter</a>.</p>
<form method="get" action="https://www.marketbeat.com/newsletter/default.aspx">
<input id="BelowPostRegistrationEmail" name="RegisterEmail" type="email" placeholder="Your Email Address" aria-label="Your Email Address" class="signup" />
<input type="hidden" id="Hidden3" name="RegistrationCode" value="WKRB News-Footer" />
<input type="hidden" id="Hidden4" name="RegisterTicker" value="NYSE:WPC" /><input class="button" type="submit" name="submit" onclick="return CheckEmail('BelowPostRegistrationEmail','ShowSuggestionFooter');" value="Sign-Up Now (Free)">
</form>
<div id="ShowSuggestionFooter"></div>
<!-- End Footer Opt-In -->

				</div> <!-- end: entry -->
				<!--/sse-->
				 				<!-- start article metadata -->
				 <div itemscope itemprop="image" itemtype="https://schema.org/ImageObject" style='display:none'>
 					<link itemprop="url" href="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?w=500&h=300&zc=2&src=https://www.marketbeat.com/logos/w-p-carey-logo.jpg" />
 					<meta itemprop="width" content="500">
 					<meta itemprop="height" content="300">
				 </div>
				<div itemscope itemprop="publisher" itemtype="https://schema.org/Organization" style="display:none">
 					<div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
					 	<meta itemprop="url" content="https://www.wkrb13.com/wp-content/uploads/2021/05/wkrb-logo-01.png">
						  						 <meta itemprop="width" content="844">
						 <meta itemprop="height" content="336">
					 </div>
					<meta itemprop="name" content="WKRB News"/>
					<meta itemprop="url" content="https://wkrb13.com" />
 				</div>
				<!-- end article metadata -->
			</article>


<!-- More on MarketBeat -->
<iframe width="100%" height="600" scrolling="no" frameborder="no" src="https://www.marketbeat.com/scripts/MoreOnMarketBeatBelowPost.aspx" title="More Headlines"></iframe>
<!-- More on MarketBeat -->

<!--  below post unit position -->
		

			<nav id="prevnext"><!-- previous and next article links -->
				<a href="https://www.wkrb13.com/2022/04/10/agf-investments-inc-trims-holdings-in-jpmorgan-chase-co-nysejpm.html" rel="prev"><div class="previous"><h2 class="h4">&laquo; PREVIOUS HEADLINE</h2><p>AGF Investments Inc. Trims Holdings in JPMorgan Chase &#038; Co. (NYSE:JPM)</p></div></a>				<a href="https://www.wkrb13.com/2022/04/10/the-allstate-co-nyseall-shares-sold-by-rfg-advisory-llc.html" rel="next"><div class="next"><h2 class="h4">NEXT HEADLINE &raquo;</h2><p>The Allstate Co. (NYSE:ALL) Shares Sold by RFG Advisory LLC</p></div></a>			
			</nav><!-- end previous and next article links -->
			
		
		<div id="latest-news">
				
				<h2>You might be interested in:</h2>
			 				 <div class="latest-news-item">
												<div class="item-image-bar"><div class="item-image-wrapper"><img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/procter--gamble-logo.gif&amp;h=45&amp;w=95&amp;zc=2" width="65" height="31" alt="Castle Rock Wealth Management LLC Sells 81 Shares of The Procter &#038; Gamble Company " />
						</div></div>
				 <!--end: longthumb-->
						<a href="https://www.wkrb13.com/2022/04/10/castle-rock-wealth-management-llc-sells-81-shares-of-the-procter-gamble-company-nysepg.html" rel="bookmark">Castle Rock Wealth Management LLC Sells 81 Shares of The Procter &#038; Gamble Company </a>
				</div>
	 							 <div class="latest-news-item">
												<div class="item-image-bar"><div class="item-image-wrapper"><img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/invesco-sp-500-equal-weight-industrials-etf-logo.jpg?v=20210824092312&amp;h=45&amp;w=95&amp;zc=2" width="65" height="31" alt="Castle Rock Wealth Management LLC Increases Stock Holdings in Invesco S&#038;P 500 Equal Weight Industrials ETF " />
						</div></div>
				 <!--end: longthumb-->
						<a href="https://www.wkrb13.com/2022/04/10/castle-rock-wealth-management-llc-increases-stock-holdings-in-invesco-sp-500-equal-weight-industrials-etf-nysearcargi.html" rel="bookmark">Castle Rock Wealth Management LLC Increases Stock Holdings in Invesco S&#038;P 500 Equal Weight Industrials ETF </a>
				</div>
	 							 <div class="latest-news-item">
												<div class="item-image-bar"><div class="item-image-wrapper"><img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/canyon-copper-corp-logo.jpg&amp;h=45&amp;w=95&amp;zc=2" width="65" height="31" alt="RFG Advisory LLC Has $1.30 Million Holdings in Centene Co. " />
						</div></div>
				 <!--end: longthumb-->
						<a href="https://www.wkrb13.com/2022/04/10/rfg-advisory-llc-has-1-30-million-holdings-in-centene-co-nysecnc.html" rel="bookmark">RFG Advisory LLC Has $1.30 Million Holdings in Centene Co. </a>
				</div>
	 							 <div class="latest-news-item">
												<div class="item-image-bar"><div class="item-image-wrapper"><img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/costco-logo.jpg&amp;h=45&amp;w=95&amp;zc=2" width="65" height="31" alt="Mount Yale Investment Advisors LLC Decreases Stock Holdings in Costco Wholesale Co. " />
						</div></div>
				 <!--end: longthumb-->
						<a href="https://www.wkrb13.com/2022/04/10/mount-yale-investment-advisors-llc-decreases-stock-holdings-in-costco-wholesale-co-nasdaqcost.html" rel="bookmark">Mount Yale Investment Advisors LLC Decreases Stock Holdings in Costco Wholesale Co. </a>
				</div>
	 							 <div class="latest-news-item">
												<div class="item-image-bar"><div class="item-image-wrapper"><img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/ciena-corp-logo.jpg&amp;h=45&amp;w=95&amp;zc=2" width="65" height="31" alt="$951.02 Million in Sales Expected for Ciena Co.  This Quarter" />
						</div></div>
				 <!--end: longthumb-->
						<a href="https://www.wkrb13.com/2022/04/10/951-02-million-in-sales-expected-for-ciena-co-nysecien-this-quarter.html" rel="bookmark">$951.02 Million in Sales Expected for Ciena Co.  This Quarter</a>
				</div>
	 							 <div class="latest-news-item">
												<div class="item-image-bar"><div class="item-image-wrapper"><img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/lawson-products-inc-logo.png&amp;h=45&amp;w=95&amp;zc=2" width="65" height="31" alt="Brokerages Expect Lawson Products, Inc.  Will Announce Quarterly Sales of $110.15 Million" />
						</div></div>
				 <!--end: longthumb-->
						<a href="https://www.wkrb13.com/2022/04/10/brokerages-expect-lawson-products-inc-nasdaqlaws-will-announce-quarterly-sales-of-110-15-million.html" rel="bookmark">Brokerages Expect Lawson Products, Inc.  Will Announce Quarterly Sales of $110.15 Million</a>
				</div>
	 						</div><!-- end latest news -->

<!-- second ad spot -->

<br>
	</main> <!-- end main -->
<aside class="flex-sidebar">
<div class="flex-container">	
<div class="sidebar-section">
	
<iframe src="https://marketbeat.com/scripts/MoreOnMarketBeat.aspx" width="336" height="600" frameborder="no" title="More Articles"></iframe><br><br>
	
<!-- Network Wide AdSense Unit - Top Sidebar Position -->
<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-9373162611283935" data-ad-slot="1875628183" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>(adsbygoogle = window.adsbygoogle || []).push({});</script>
<!-- End AdSense Unit -->
<br><br>
<!-- end first square unit -->

<!-- Network Wide AdSense Unit - Middle Sidebar Position -->
<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-9373162611283935" data-ad-slot="9445683366" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>(adsbygoogle = window.adsbygoogle || []).push({});</script>
<!-- End AdSense Unit -->
<br><br>	
<!-- end second square unit -->
		
</div>	
<div class="sidebar-section">
<!-- OptIn Form -->

<!-- Start Sidebar Registration -->
<div class="sidebar-email">
                        <h3>Daily Ratings &amp; News for W. P. Carey</h3>
        	Complete the form below to receive the latest headlines and analysts' recommendations for W. P. Carey with our free daily email newsletter:<br/>
        <form method="get" action="https://www.marketbeat.com/newsletter/default.aspx">
        <input id="RegisterEmailSidebar" style='width:100%' name="RegisterEmail" type="email" placeholder="Your Email Address" aria-label="Your Email Address">
        <input type="hidden" id="Hidden7" name="RegistrationCode" value="WKRB News-Sidebar">
        <input type="hidden" id="Hidden8" name="RegisterTicker" value="NYSE:WPC" />        <input type="submit" name="submit" onclick="return CheckEmail('RegisterEmailSidebar', 'ShowSuggestionSidebar');" value="Subscribe Now (Free Sign-Up)" class="button" style="width:100%;height:30px">
    <div id="ShowSuggestionSidebar" style="padding-top:7px"></div>
    </form>
    </div>

<!-- End Sidebar Registration -->
	
<!-- optional social media -->
	
 
		<br>
	
	<a style="background: #075A8D;color: #fff;padding: 5px 7px 4px;border-radius: 3px;font-size: 12px;text-decoration: none;" href="https://twitter.com/intent/follow?original_referer=https%3A%2F%2Fwww.wkrb13.com%2F&ref_src=twsrc%5Etfw&screen_name=WKRBnews" target="_blank" rel="noopener nofollow">
<svg style="width: 13px;vertical-align: middle;margin-right: 4px;fill: #fff;" xmlns="http://www.w3.org/2000/svg" width="24" height="24" viewBox="0 0 24 24"><path d="M24 4.557c-.883.392-1.832.656-2.828.775 1.017-.609 1.798-1.574 2.165-2.724-.951.564-2.005.974-3.127 1.195-.897-.957-2.178-1.555-3.594-1.555-3.179 0-5.515 2.966-4.797 6.045-4.091-.205-7.719-2.165-10.148-5.144-1.29 2.213-.669 5.108 1.523 6.574-.806-.026-1.566-.247-2.229-.616-.054 2.281 1.581 4.415 3.949 4.89-.693.188-1.452.232-2.224.084.626 1.956 2.444 3.379 4.6 3.419-2.07 1.623-4.678 2.348-7.29 2.04 2.179 1.397 4.768 2.212 7.548 2.212 9.142 0 14.307-7.721 13.995-14.646.962-.695 1.797-1.562 2.457-2.549z"/></svg> Follow @WKRBnews</a>
		
	
<!-- end optional social media -->

<!-- sidebar unit position -->


<!-- start Recent Posts -->
        <br/>
        <div>
        <h3>Recent News</h3>
            <ul>
                        <li class="recent-posts"><a href="https://www.wkrb13.com/2022/04/10/castle-rock-wealth-management-llc-sells-81-shares-of-the-procter-gamble-company-nysepg.html">Castle Rock Wealth Management LLC Sells 81 Shares of The Procter &#038; Gamble Company (NYSE:PG)</a></li>
                        <li class="recent-posts"><a href="https://www.wkrb13.com/2022/04/10/castle-rock-wealth-management-llc-increases-stock-holdings-in-invesco-sp-500-equal-weight-industrials-etf-nysearcargi.html">Castle Rock Wealth Management LLC Increases Stock Holdings in Invesco S&#038;P 500 Equal Weight Industrials ETF (NYSEARCA:RGI)</a></li>
                        <li class="recent-posts"><a href="https://www.wkrb13.com/2022/04/10/rfg-advisory-llc-has-1-30-million-holdings-in-centene-co-nysecnc.html">RFG Advisory LLC Has $1.30 Million Holdings in Centene Co. (NYSE:CNC)</a></li>
                        <li class="recent-posts"><a href="https://www.wkrb13.com/2022/04/10/mount-yale-investment-advisors-llc-decreases-stock-holdings-in-costco-wholesale-co-nasdaqcost.html">Mount Yale Investment Advisors LLC Decreases Stock Holdings in Costco Wholesale Co. (NASDAQ:COST)</a></li>
                        <li class="recent-posts"><a href="https://www.wkrb13.com/2022/04/10/951-02-million-in-sales-expected-for-ciena-co-nysecien-this-quarter.html">$951.02 Million in Sales Expected for Ciena Co. (NYSE:CIEN) This Quarter</a></li>
                        <li class="recent-posts"><a href="https://www.wkrb13.com/2022/04/10/brokerages-expect-lawson-products-inc-nasdaqlaws-will-announce-quarterly-sales-of-110-15-million.html">Brokerages Expect Lawson Products, Inc. (NASDAQ:LAWS) Will Announce Quarterly Sales of $110.15 Million</a></li>
                        <li class="recent-posts"><a href="https://www.wkrb13.com/2022/04/10/x42-protocol-x42-hits-one-day-trading-volume-of-767-00.html">x42 Protocol (X42) Hits One Day Trading Volume of $767.00</a></li>
                        <li class="recent-posts"><a href="https://www.wkrb13.com/2022/04/10/wolf-safe-poor-people-one-day-trading-volume-reaches-6975-00-wspp.html">Wolf Safe Poor People One Day Trading Volume Reaches $6,975.00 (WSPP)</a></li>
                        <li class="recent-posts"><a href="https://www.wkrb13.com/2022/04/10/solana-24-hour-trading-volume-reaches-1-06-billion-sol.html">Solana 24 Hour Trading Volume Reaches $1.06 Billion (SOL)</a></li>
                        <li class="recent-posts"><a href="https://www.wkrb13.com/2022/04/10/tradestars-price-hits-0-0834-on-major-exchanges-tsx.html">TradeStars Price Hits $0.0834 on Major Exchanges (TSX)</a></li>
                        <li class="recent-posts"><a href="https://www.wkrb13.com/2022/04/10/lightstreams-1-day-trading-volume-tops-167-00-pht.html">Lightstreams 1-Day Trading Volume Tops $167.00 (PHT)</a></li>
                        <li class="recent-posts"><a href="https://www.wkrb13.com/2022/04/10/mimblewimblecoin-price-reaches-9-36-mwc.html">MimbleWimbleCoin Price Reaches $9.36  (MWC)</a></li>
                        <li class="recent-posts"><a href="https://www.wkrb13.com/2022/04/10/smartkey-price-tops-0-24-on-top-exchanges-skey.html">SmartKey Price Tops $0.24 on Top Exchanges (SKEY)</a></li>
                        <li class="recent-posts"><a href="https://www.wkrb13.com/2022/04/10/rfg-advisory-llc-has-1-46-million-position-in-iron-mountain-incorporated-nyseirm.html">RFG Advisory LLC Has $1.46 Million Position in Iron Mountain Incorporated (NYSE:IRM)</a></li>
                        <li class="recent-posts"><a href="https://www.wkrb13.com/2022/04/10/rfg-advisory-llc-sells-358-shares-of-broadcom-inc-nasdaqavgo.html">RFG Advisory LLC Sells 358 Shares of Broadcom Inc. (NASDAQ:AVGO)</a></li>
                        <li class="recent-posts"><a href="https://www.wkrb13.com/2022/04/10/waldron-private-wealth-llc-makes-new-224000-investment-in-paccar-inc-nasdaqpcar.html">Waldron Private Wealth LLC Makes New $224,000 Investment in PACCAR Inc (NASDAQ:PCAR)</a></li>
                        <li class="recent-posts"><a href="https://www.wkrb13.com/2022/04/10/tradewinds-capital-management-llc-purchases-3000-shares-of-transocean-ltd-nyserig.html">Tradewinds Capital Management LLC Purchases 3,000 Shares of Transocean Ltd. (NYSE:RIG)</a></li>
                        <li class="recent-posts"><a href="https://www.wkrb13.com/2022/04/10/rfg-advisory-llc-has-343000-position-in-salesforce-com-inc-nysecrm.html">RFG Advisory LLC Has $343,000 Position in salesforce.com, inc. (NYSE:CRM)</a></li>
                        <li class="recent-posts"><a href="https://www.wkrb13.com/2022/04/10/the-allstate-co-nyseall-shares-sold-by-rfg-advisory-llc.html">The Allstate Co. (NYSE:ALL) Shares Sold by RFG Advisory LLC</a></li>
                        <li class="recent-posts"><a href="https://www.wkrb13.com/2022/04/10/rfg-advisory-llc-cuts-stock-holdings-in-w-p-carey-inc-nysewpc.html">RFG Advisory LLC Cuts Stock Holdings in W. P. Carey Inc. (NYSE:WPC)</a></li>
                        </ul>
        </div>  
</div>
</div>
<!-- end recent posts -->
</aside><!--end #sidebar-->
	<div style="clear: both;"></div>
</div> <!-- end .width-limiter -->
<footer class="full-width">
	<div class="width-limiter flex-container">
		<div id="footer-info" class="add-padding flex-nav">
			<nav class="navigation" aria-label="Category Links"><ul id="menu-category-menu-2" class="menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-31"><a href="https://www.wkrb13.com/category/markets">Markets</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-60"><a href="https://www.wkrb13.com/category/markets/analyst-articles-us">Ratings</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-54"><a href="https://www.wkrb13.com/category/markets/dividend-articles">Dividends</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-55"><a href="https://www.wkrb13.com/category/markets/earnings-articles-single">Earnings</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56"><a href="https://www.wkrb13.com/category/markets/insider-trades">Insider Trades</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24"><a href="https://www.wkrb13.com/category/markets/cryptocurrencies">Cryptocurrencies</a></li>
</ul></nav>		</div><!-- end #footer-info -->
		<span id="copyright" class="add-padding flex-copyright">
				&copy; 2018-2022 <a href="https://www.wkrb13.com">WKRB News</a>
	    </span>
	</div>	
	<!-- Begin Internal Tracking Pixel 2 -->
		<script type='text/javascript'>document.write('<img src="https://www.american' + 'consumernews.net/scripts/standalone/viewcount.ashx?ArticleHistoryID=87493503&PostDate=2022-4-10&type=f&id=11472886&domain=www.wkrb13.com&referrer=' + encodeURIComponent(document.referrer) + '" alt="" width="1" height="1" style="float:left;" />');</script>
		<!-- End Internal Tracking Pixel 2-->
</footer>
		<script type='text/javascript' src='https://www.wkrb13.com/wp-includes/js/wp-embed.min.js?ver=5.5.9' id='wp-embed-js'></script>
</div>
<!-- MarketBeat News Network StatCounter Code -->
<script type="text/javascript">var sc_project=9021069; var sc_invisible=1; var sc_security="fdde5482"; var sc_https=1; </script>
<script type="text/javascript" src="https://www.statcounter.com/counter/counter.js"></script>
<noscript><img class="statcounter" src="https://c.statcounter.com/9021069/0/fdde5482/1/" height="1" width="1" alt=""></noscript>
<!-- End MarketBeat News Network StatCounter Code -->

<!-- Start of Site Specific StatCounter Code -->
<script type="text/javascript">
var sc_project=11650630; 
var sc_invisible=1; 
var sc_security="2798fb99"; 
</script>
<script type="text/javascript" src="https://www.statcounter.com/counter/counter.js"></script>
<noscript><img class="statcounter" src="https://c.statcounter.com/11650630/0/2798fb99/1/" height="1" width="1"  alt=""></noscript>
<!-- End of Site Specific StatCounter Code -->

	</body>
</html>
