<!doctype html>
<html lang="en">
<head>
<meta name="distribution" content="global" />
<meta name="robots" content="follow, all" />
<meta content="text/html; charset=UTF-8" http-equiv="Content-Type" />

<meta name="theme-color" content="#081c59"/>
 

<meta name="viewport" content="width=device-width, initial-scale=1.0">

<!-- Escape from Frames -->
<script type="text/javascript">if(self==top){document.documentElement.style.display="block"}else{top.location=self.location}</script>

<link rel="preconnect" href="https://fonts.gstatic.com">
<link href="https://fonts.googleapis.com/css2?family=Roboto&display=swap" rel="stylesheet">


<style>

:root {
  --header-background: #ffffff;
  --button-background: #081c59;
  --button-background-2: #081c59;
  --button-hover-background: #0e30a0;
  --button-hover-background-2: #0e30a0;
  --button-text-color: #fff;
  --link-color: #0e309e;
  --link-hover-color: #0e309e;
  --link-text-decoration: none; /* text field */
  --hover-link-text-decoration: underline; /* text field */
  --menu-background: #eaeaea;
  --menu-background-2: #eaeaea;
  --menu-text-color: #081c59;
  --menu-active-hover-background: #081c59;
  --menu-active-hover-text-color: #fff;
  --top-menu-background: #f2ac07;
  --top-menu-link-color: #081c59;
  --top-menu-link-hover-color: #0e309e;
  --accent-color: #0e309e;
  --accent-color-2: #081c59;
  --sidebar-h3-color: #081c59;
  --light-gray-color:#eaeaea;
  --light-gray-link-color:#eaeaea;
  --light-gray-link-hover-color:#eaeaea;
  --list-item-bottom-border: solid 1px #f2ac07;
  --border-radius: 0;
  --border-radius-small-items: 0;
  --H1-font: bold 2em/1.3 'Roboto',sans-serif;
  --H2-font:  bold 1.3em/1.3 'Roboto',sans-serif;
  --H3-font:  bold uppercase 1.1em/1.3 'Roboto',sans-serif;
  --body-font: 15px 'Roboto',sans-serif;
  --menu-font: 1em 'Roboto', sans-serif;
  --box-shadow: 0px 0px 3px 0px #f2ac07; 
  --body-background: #061442;
  --body-background-2: #0e30a1;
  --body-font-color: #555555;

}


body {
	font: var(--body-font);
    background: var(--body-background);
	color: var(--body-font-color);
	 
		
	background: -moz-linear-gradient(top, var(--body-background) 0%, var(--body-background-2) 100%);
    background: -webkit-gradient(left top,left bottom,color-stop(0%, var(--body-background)),color-stop(100%, var(--body-background-2)));
    background: -webkit-linear-gradient(top, var(--body-background) 0%, var(--body-background-2) 100%);
    background: -o-linear-gradient(top, var(--body-background) 0%, var(--body-background-2) 100%);
    background: -ms-linear-gradient(top, var(--body-background) 0%, var(--body-background-2) 100%);
    background: linear-gradient(to bottom, var(--body-background) 0%, var(--body-background-2) 100%);
		
    background-attachment: fixed;
    background-size: cover;
}

</style>
<link rel="stylesheet" href="https://www.wkrb13.com/wp-content/themes/responsalambre/style.css?v=2021abcdefghij" type="text/css" media="screen">
	
<link href="https://www.wkrb13.com/feed" rel="alternate" title="WKRB News RSS Feed" type="application/rss+xml" />
<link href="https://www.wkrb13.com/feed/atom" rel="alternate" title="WKRB News Atom Feed" type="application/atom+xml" />
<link href="https://www.wkrb13.com/xmlrpc.php" rel="pingback" />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://www.wkrb13.com/wp-includes/css/dist/block-library/style.min.css?ver=5.5.10' type='text/css' media='all' />
<link rel="https://api.w.org/" href="https://www.wkrb13.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.wkrb13.com/wp-json/wp/v2/posts/4899019" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.wkrb13.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.wkrb13.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Elmwood Wealth Management Inc. Acquires 1,850 Shares of Global X Renewable Energy Producers ETF (NYSEARCA:RNRG)' href='https://www.wkrb13.com/2022/09/19/elmwood-wealth-management-inc-acquires-1850-shares-of-global-x-renewable-energy-producers-etf-nysearcarnrg.html' />
<link rel='next' title='Archford Capital Strategies LLC Purchases 977 Shares of AmerisourceBergen Co. (NYSE:ABC)' href='https://www.wkrb13.com/2022/09/19/archford-capital-strategies-llc-purchases-977-shares-of-amerisourcebergen-co-nyseabc.html' />
<meta name="generator" content="WordPress 5.5.10" />
<link rel="canonical" href="https://www.wkrb13.com/2022/09/19/elmwood-wealth-management-inc-sells-808-shares-of-mccormick-company-incorporated-nysemkc.html" />
<link rel='shortlink' href='https://www.wkrb13.com/?p=4899019' />
<link rel="alternate" type="application/json+oembed" href="https://www.wkrb13.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.wkrb13.com%2F2022%2F09%2F19%2Felmwood-wealth-management-inc-sells-808-shares-of-mccormick-company-incorporated-nysemkc.html" />
<link rel="alternate" type="text/xml+oembed" href="https://www.wkrb13.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.wkrb13.com%2F2022%2F09%2F19%2Felmwood-wealth-management-inc-sells-808-shares-of-mccormick-company-incorporated-nysemkc.html&#038;format=xml" />
<link rel="manifest" href="https://www.wkrb13.com/manifest.json"><link rel="amphtml" href="https://www.wkrb13.com/2022/09/19/elmwood-wealth-management-inc-sells-808-shares-of-mccormick-company-incorporated-nysemkc.html/amp" /><link rel="icon" href="https://www.wkrb13.com/wp-content/uploads/2018/03/wkrb13-03-150x150.png" sizes="32x32" />
<link rel="icon" href="https://www.wkrb13.com/wp-content/uploads/2018/03/wkrb13-03.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.wkrb13.com/wp-content/uploads/2018/03/wkrb13-03.png" />
<meta name="msapplication-TileImage" content="https://www.wkrb13.com/wp-content/uploads/2018/03/wkrb13-03.png" />

<!-- Start Meta Data -->
<title>Elmwood Wealth Management Inc. Sells 808 Shares of McCormick &#038; Company, Incorporated (NYSE:MKC) - WKRB News</title>
<meta name="description" content="Read Elmwood Wealth Management Inc. Sells 808 Shares of McCormick &#038; Company, Incorporated (NYSE:MKC) at WKRB News"/>
<meta name="distribution" content="global" />
<meta name="robots" content="follow, all" />
<meta name="description" content="Elmwood Wealth Management Inc. trimmed its holdings in shares of McCormick &#038; Company, Incorporated (NYSE:MKC &#8211; Get Rating) by 6.0% in the second quarter, according to the company in its most recent filing with the Securities and Exchange Commission. The institutional investor owned 12,701 shares of the company&#8217;s stock after selling 808 shares during the [&hellip;]" />
<meta name="author" content="Lisa Pomrenke">
<meta name="news_keywords" content="McCormick & Company Incorporated,NYSE:MKC,MKC,Consumer Staple,57978020,SEC Filings,13F,Hedge Fund Holdings,Institutional Investor Holdings" />
<meta name="keywords" content="McCormick & Company Incorporated,NYSE:MKC,MKC,Consumer Staple,57978020,SEC Filings,13F,Hedge Fund Holdings,Institutional Investor Holdings" />
<meta name="ticker" content="NYSE:MKC" />
<meta name="contentType" content="article">

<!-- Twitter Card Data -->
<meta name="twitter:card" content="summary"/>
<meta name="twitter:site" content="@MarketBeatCom" />
<meta name="twitter:title" content="Elmwood Wealth Management Inc. Sells 808 Shares of McCormick &#038; Company, Incorporated (NYSE:MKC)"/>
<meta name="twitter:description" content="Elmwood Wealth Management Inc. trimmed its holdings in shares of McCormick &#038; Company, Incorporated (NYSE:MKC &#8211; Get Rating) by 6.0% in the second quarter, according to the company in its most recent filing with the Securities and Exchange Commission. The institutional investor owned 12,701 shares of the company&#8217;s stock after selling 808 shares during the [&hellip;]" />
<meta name="twitter:creator" content="@RatingsNetwork" />
<meta name="twitter:image" content="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/mccormick-amp;-company-incorporated-logo.jpg&amp;w=240&amp;h=240&amp;zc=2" />

<!-- Open Graph Data -->
<meta property="og:title" content="Elmwood Wealth Management Inc. Sells 808 Shares of McCormick &#038; Company, Incorporated (NYSE:MKC)" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.wkrb13.com/2022/09/19/elmwood-wealth-management-inc-sells-808-shares-of-mccormick-company-incorporated-nysemkc.html" />
<meta property="og:image" content="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/mccormick-amp;-company-incorporated-logo.jpg&amp;w=240&amp;h=240&amp;zc=2" />
<meta property="og:image:width" content="240" />
<meta property="og:image:height" content="240" />
<meta property="og:description" content="Elmwood Wealth Management Inc. trimmed its holdings in shares of McCormick &#038; Company, Incorporated (NYSE:MKC &#8211; Get Rating) by 6.0% in the second quarter, according to the company in its most recent filing with the Securities and Exchange Commission. The institutional investor owned 12,701 shares of the company&#8217;s stock after selling 808 shares during the [&hellip;]" />
<meta property="og:site_name" content="WKRB News" />
<meta property="og:locale" content="en_US" />

<!-- OG Article Template -->
<meta property="article:published_time" content="2022-09-19T13:58:42+0000" />
<meta property="article:modified_time" content="2022-09-19T13:58:42+0000" />
<meta property="article:tag" content="NYSE:MKC" />
<meta property="article:tag" content="McCormick & Company Incorporated,NYSE:MKC,MKC,Consumer Staple,57978020,SEC Filings,13F,Hedge Fund Holdings,Institutional Investor Holdings" />
<meta property="article:section" content="Markets" />

<!-- Google meta is in the body-->

<!-- End Meta Data -->

	
<script type='text/javascript'>var PopupAdChannel=''; </script>

  <link rel="manifest" href="/manifest.json">
  <script src="https://cdn.onesignal.com/sdks/OneSignalSDK.js"></script>
  <script>
  	function registerUserChange(action) {
		OneSignal.getUserId( function(userId) {
			OneSignalIdString = userId;
			var Domain = 'wkrb13.com';
			var url = "https://www.marketbeat.com/scripts/OneSignalTracking.ashx?OneSignalID=" + OneSignalIdString + "&domain=" + Domain + "&action=" + action;
			var xhr = new XMLHttpRequest();
			xhr.open('GET', url);
			xhr.onload = function () {
				if (xhr.status !== 200) {
					console.log('GET failed.  Returned status of ' + xhr.status);
				}
			};
			xhr.send();
		});
	}
    var OneSignal = window.OneSignal || [];
    OneSignal.push(["init", {
      appId: "27539f7d-08b9-4089-9eac-48d0d5b908a5",
      safari_web_id: 'web.onesignal.auto.54cd441e-7f12-4aed-9845-f98eb5c10ecb', 
      autoRegister: false,
      notifyButton: {
        enable: false /* Set to false to hide */
      },
 welcomeNotification: {
        "title": "Join Wall Street's Brightest Minds.",
        "message": "Receive research in your inbox from top analysts, before the market opens. Click here to learn how.",
         "url": "https://www.marketbeat.com/subscribe/subscribe.aspx?ReferralType=OneSignalThankYou&ProductCode=1997t"
    }
    },
		OneSignal.once('subscriptionChange', function (isSubscribed) {
			if(isSubscribed) {
				registerUserChange("subscribe");
			}
			else {
				registerUserChange("unsubscribe");
			}
			
		  })
	]);
if((navigator.userAgent.toLowerCase().indexOf('firefox') > -1)||((navigator.userAgent.toLowerCase().indexOf('safari') > -1)&&(!(navigator.userAgent.toLowerCase().indexOf('chrome') > -1)))){
		OneSignal.showSlidedownPrompt();
	} else {
		OneSignal.showNativePrompt();		
	}  </script>



<script type="text/javascript">var vbnfgha = '211626'; var ertdfga = '13739-bup-ac'; var qhyuioa = '53938'; var AdClientID = qhyuioa + vbnfgha + ertdfga; AdClientID = AdClientID.split("").reverse().join("");</script>


	
	<script type="text/javascript" src="https://www.marketbeat.com/Scripts/lowerrightad.js?v=2021"></script>
	
	<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({
          google_ad_client: AdClientID,
          enable_page_level_ads: false
     });
</script>

</head>
<body>
<div id="wrap">
<script type="text/javascript" src="https://www.marketbeat.com/scripts/modal/modernpopup.js?v=60"></script>
	
<!-- Start MarketBeat Modern Popup -->
<link rel="stylesheet" type="text/css" media="all" href="https://www.marketbeat.com/scripts/modal/modernpopup.css?v=12"/>
	
	
	<script type="text/javascript">LoadPopupRatings('ModernMarketsPopup-WKRB News', 'wkrb13.com', 'NYSE:MKC', 'McCormick & Company Incorporated', 'https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?w=175&zc=1&src=https://www.marketbeat.com/logos/mccormick-amp;-company-incorporated-logo.jpg');</script>
	<!-- End MarketBeat Modern Popup -->
	
<a class="skip-link scroll" href="#main">Skip to main content</a>
<header>
	<div class="width-limiter background-light top-menu-bar">
		<div style='color:#222;text-align:right;'>
			<nav class="navigation top-menu" aria-label="Utility Links"><ul id="menu-top-bar" class="menu"><li id="menu-item-19" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-19"><a href="https://wkrb13.com">Home</a></li>
<li id="menu-item-18" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-18"><a href="https://www.wkrb13.com/about">About</a></li>
<li id="menu-item-17" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-17"><a href="https://www.wkrb13.com/daily-email-updates-basic">Daily Email Updates</a></li>
<li id="menu-item-47" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-47"><a href="https://www.wkrb13.com/privacy-policy">Privacy Policy</a></li>
</ul></nav>		</div>
   </div>
<!-- start for mobile menu -->
<div class="width-limiter top-mobile-menu" id='mobile-logo-bar'>
	 <label for="nav-trigger" style="display:inline-block; width:30vw; color:#12424d;vertical-align:middle;">&#9776;</label> 
	 <a style='vertical-align:middle;width:33vw;display:inline-block;text-align:center;padding:5px;' href="https://www.wkrb13.com"><img style='width:120px' src="https://www.wkrb13.com/wp-content/uploads/2021/05/wkrb-logo-01.png" alt="WKRB News logo" width="844" height="336"></a>
	</div>
	<div class="width-limiter" style="min-height: 5px;" id='mobile-menu-bar'>
		
                	<input type="checkbox" id="nav-trigger" class="navOpen" />
                
                	<div class="mobile-nav nice-scroll">
                		
							
                			
                			<nav class="mobile-menu" aria-label="Category Mobile Menu"><ul id="menu-category-menu" class="menu"><li id="menu-item-31" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-31"><a href="https://www.wkrb13.com/category/markets">Markets</a></li>
<li id="menu-item-60" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-60"><a href="https://www.wkrb13.com/category/markets/analyst-articles-us">Ratings</a></li>
<li id="menu-item-54" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-54"><a href="https://www.wkrb13.com/category/markets/dividend-articles">Dividends</a></li>
<li id="menu-item-55" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-55"><a href="https://www.wkrb13.com/category/markets/earnings-articles-single">Earnings</a></li>
<li id="menu-item-56" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56"><a href="https://www.wkrb13.com/category/markets/insider-trades">Insider Trades</a></li>
<li id="menu-item-24" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24"><a href="https://www.wkrb13.com/category/markets/cryptocurrencies">Cryptocurrencies</a></li>
</ul></nav>                			<nav class="mobile-menu" aria-label="Utility Mobile Menu"><ul id="menu-top-bar-1" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-19"><a href="https://wkrb13.com">Home</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-18"><a href="https://www.wkrb13.com/about">About</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-17"><a href="https://www.wkrb13.com/daily-email-updates-basic">Daily Email Updates</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-47"><a href="https://www.wkrb13.com/privacy-policy">Privacy Policy</a></li>
</ul></nav>                			
                			<form class="mobile-search" id="mobileSearchForm" action="https://www.wkrb13.com/" method="get">
                				<div class="search">
                					<input id="s" style='margin-left:0;' class="searchinput" aria-label="Search Keywords" name="s" onclick="this.value='';" type="text" />
                					<input class="searchsubmit" type="submit" value="SEARCH" />
                				</div>
                			</form>
						<div>
	
						</div>
                	</div>
		
	</div>
<!-- end for mobile menu -->
	<div class="width-limiter add-padding flex-container"><!-- start: width-limiter with logo and space for alternate header unit -->
		
		<a class="logo-link flex-logo" id="header-logo-link" href="https://www.wkrb13.com" title="WKRB News"><img id="logo" src="https://www.wkrb13.com/wp-content/uploads/2021/05/wkrb-logo-01.png" alt="WKRB News logo" width="844" height="336"></a>

<!-- Begin Header Unit -->
<div id="AlternateHeaderUnit" class="flex-header-ad">
	<iframe class="large-show" src="https://marketbeat.com/scripts/HeaderAdNewsSites.ashx" width="728" height="110" frameborder="no" scrolling="no" style="width: 100%;overflow:hidden;" title="Ad"></iframe>
	<iframe class="small-show" src="https://marketbeat.com/scripts/SidebarAdNewsSites.ashx" width="336" height="280" frameborder="no"scrolling="no" style="overflow:hidden;margin:0 auto;" title="Ad"></iframe>
</div> 

<!-- End Header Unit-->
	</div> <!-- end: width-limiter with logo and space for alternate header unit -->
	<div id="menu">
		<div class="width-limiter flex-container" id="nav-main">
			
			<!-- start main category menu -->
			
			<div class="flex-nav">
			   
			  



			<nav class="navigation" aria-label="Main Menu"><ul id="menu-category-menu-1" class="menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-31"><a href="https://www.wkrb13.com/category/markets">Markets</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-60"><a href="https://www.wkrb13.com/category/markets/analyst-articles-us">Ratings</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-54"><a href="https://www.wkrb13.com/category/markets/dividend-articles">Dividends</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-55"><a href="https://www.wkrb13.com/category/markets/earnings-articles-single">Earnings</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56"><a href="https://www.wkrb13.com/category/markets/insider-trades">Insider Trades</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24"><a href="https://www.wkrb13.com/category/markets/cryptocurrencies">Cryptocurrencies</a></li>
</ul></nav>			
			</div>
				<form class="flex-search" id="searchform" action="https://www.wkrb13.com/" method="get">
					<div class="search">
						<input id="s-main" class="searchinput" name="s" aria-label="Search Keywords" onclick="this.value='';" type="text" />
						<input class="searchsubmit" type="submit" value="SEARCH" />
					</div>
					
				</form><!-- end: searchform -->
		</div> <!-- end: width-limiter for menu -->
	</div> <!-- end: menu -->
</header> <!-- end: header -->
	<div class="width-limiter main-content flex-container">
		

		<main class="flex-main" id="main">
			 <article itemscope itemtype="http://schema.org/NewsArticle">
				
				<link itemprop="mainEntityOfPage" href="https://www.wkrb13.com/2022/09/19/elmwood-wealth-management-inc-sells-808-shares-of-mccormick-company-incorporated-nysemkc.html" />
				<h1 itemprop="headline" class="page-title">Elmwood Wealth Management Inc. Sells 808 Shares of McCormick &#038; Company, Incorporated (NYSE:MKC)</h1>

				<p class="postmeta">
					Posted by <span itemprop="author" itemscope itemtype="https://schema.org/Person"><span itemprop="name"><a href="https://www.wkrb13.com/author/lisap" title="Posts by Lisa Pomrenke" rel="author">Lisa Pomrenke</a></span></span> on <span itemprop="datePublished dateModified" content="2022-09-19T13:58:42+0000">Sep 19th, 2022</span>
				</p><!--end .postmeta-->

				<div class="social-shares">
					
					
		 
			
					<a title="Share on Twitter" rel="noopener nofollow" target="_blank" style="background: #1DA1F2;" href="https://twitter.com/intent/tweet?original_referer=https%3A%2F%2Fwww.wkrb13.com&ref_src=twsrc%5Etfw&text=Elmwood%20Wealth%20Management%20Inc.%20Sells%20808%20Shares%20of%20McCormick%20%26%20Company%2C%20Incorporated%20%28NYSE%3AMKC%29%20%24MKC&tw_p=tweetbutton&url=https%3A%2F%2Fwww.wkrb13.com%2F2022%2F09%2F19%2Felmwood-wealth-management-inc-sells-808-shares-of-mccormick-company-incorporated-nysemkc.html&via=WKRBnews"><span class="share-button"><svg style="fill: #fff;" xmlns="http://www.w3.org/2000/svg" width="24" height="24" viewBox="0 0 24 24"><path d="M24 4.557c-.883.392-1.832.656-2.828.775 1.017-.609 1.798-1.574 2.165-2.724-.951.564-2.005.974-3.127 1.195-.897-.957-2.178-1.555-3.594-1.555-3.179 0-5.515 2.966-4.797 6.045-4.091-.205-7.719-2.165-10.148-5.144-1.29 2.213-.669 5.108 1.523 6.574-.806-.026-1.566-.247-2.229-.616-.054 2.281 1.581 4.415 3.949 4.89-.693.188-1.452.232-2.224.084.626 1.956 2.444 3.379 4.6 3.419-2.07 1.623-4.678 2.348-7.29 2.04 2.179 1.397 4.768 2.212 7.548 2.212 9.142 0 14.307-7.721 13.995-14.646.962-.695 1.797-1.562 2.457-2.549z"/></svg></span><span class="share-title">Share on Twitter</span></a>
					
					
	<a title="Share on Facebook" rel="noopener nofollow" target="_blank" style="background:#4267B2;" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.wkrb13.com%2F2022%2F09%2F19%2Felmwood-wealth-management-inc-sells-808-shares-of-mccormick-company-incorporated-nysemkc.html"><span class="share-button"><svg style="fill: #fff;" xmlns="http://www.w3.org/2000/svg" width="24" height="24" viewBox="0 0 24 24"><path d="M9 8h-3v4h3v12h5v-12h3.642l.358-4h-4v-1.667c0-.955.192-1.333 1.115-1.333h2.885v-5h-3.808c-3.596 0-5.192 1.583-5.192 4.615v3.385z"/></svg></span><span class="share-title">Share on Facebook</span></a>
				 
<a title="Share on LinkedIn" rel="noopener nofollow" target="_blank" style="background: #0067b1;" href="https://www.linkedin.com/shareArticle?mini=true&url=https%3A%2F%2Fwww.wkrb13.com%2F2022%2F09%2F19%2Felmwood-wealth-management-inc-sells-808-shares-of-mccormick-company-incorporated-nysemkc.html"><span class="share-button"><svg style="fill: #fff;" xmlns="http://www.w3.org/2000/svg" width="24" height="24" viewBox="0 0 24 24"><path d="M4.98 3.5c0 1.381-1.11 2.5-2.48 2.5s-2.48-1.119-2.48-2.5c0-1.38 1.11-2.5 2.48-2.5s2.48 1.12 2.48 2.5zm.02 4.5h-5v16h5v-16zm7.982 0h-4.968v16h4.969v-8.399c0-4.67 6.029-5.052 6.029 0v8.399h4.988v-10.131c0-7.88-8.922-7.593-11.018-3.714v-2.155z"/></svg></span><span class="share-title">Share on LinkedIn</span></a>
				 
				<a title="Share on Stocktwits" rel="noopener nofollow" style="background:#228dff;" href="https://api.stocktwits.com/widgets/share?via=MarketBeat&amp;body=Elmwood%20Wealth%20Management%20Inc.%20Sells%20808%20Shares%20of%20McCormick%20%26%20Company%2C%20Incorporated%20%28NYSE%3AMKC%29%20%24MKC" title="Share on StockTwits"><span class="share-button"><svg style="fill:#fff;" version="1.1" id="Layer_1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink"  width="24" height="24" viewBox="0 0 30 30" style="enable-background:new 0 0 30 30;" xml:space="preserve"><polygon class="st0" points="21.98,17.75 21.98,13.29 14.54,9.67 21.98,6.19 21.98,1.84 9.02,8.45 9.02,11.12 "/><polygon class="st0" points="9.07,13.19 9.07,17.65 16.49,21.27 9.07,24.76 9.07,29.1 21.98,22.49 21.98,19.82 "/></svg></span><span class="share-title">Share on Stocktwits</span></a>
					
</div>
<div style="clear:both"></div>
				<!--sse-->
				<div class="entry" itemprop="articleBody"> 
				<!-- start main text -->
				<iframe src="https://www.marketbeat.com/scripts/TextAdNewsSites.ashx?color=0e309e" frameborder=no width="100%" height="35" scrolling="no" title="Advertisement"></iframe>

					<p><img height="150" width="250" src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?w=250&h=150&zc=2&src=https://www.marketbeat.com/logos/mccormick-amp;-company-incorporated-logo.jpg" alt="McCormick &#038; Company, Incorporated logo" title="McCormick &#038; Company, Incorporated" class="companylogo" />Elmwood Wealth Management Inc. trimmed its holdings in shares of  McCormick &#038; Company, Incorporated (<a href="https://www.marketbeat.com/stocks/NYSE/MKC/">NYSE:MKC</a> &#8211; <a style="font-weight:normal;text-decoration:italic;color:green" href="https://report.stocknews.com/sign-up/ticker/?ticker=MKC&#038;lead_source=marketbeat_snra&#038;utm_source=marketbeat_snra&#038;utm_medium=article&#038;utm_campaign=ticker&#038;utm_term=MKC&#038;utm_content=text_link">Get Rating</a>) by 6.0% in the second quarter, according to the company in its most recent filing with the Securities and Exchange Commission. The institutional investor  owned 12,701 shares of the company&#8217;s stock after selling 808 shares during the period. Elmwood Wealth Management Inc.&#8217;s holdings in McCormick &#038; Company, Incorporated were worth $1,057,000 at the end of the most recent reporting period. </p>
<p>Other institutional investors and hedge funds have also made changes to their positions in the company. Tcwp LLC acquired a new position in  McCormick &#038; Company, Incorporated in the 1st quarter valued at about $28,000.  Western Pacific Wealth Management LP grew its stake in shares of  McCormick &#038; Company, Incorporated by 50.0% in the first quarter. Western Pacific Wealth Management LP now owns 300 shares of the company&#8217;s stock valued at $29,000 after buying an additional 100 shares in the last quarter.  Riverview Trust Co purchased a new position in shares of  McCormick &#038; Company, Incorporated in the first quarter valued at $31,000.  Stonebridge Capital Advisors LLC acquired a new position in shares of  McCormick &#038; Company, Incorporated in the fourth quarter worth about $39,000.  Finally, MCF Advisors LLC acquired a new stake in  McCormick &#038; Company, Incorporated in the first quarter valued at $41,000. 78.09% of the stock is owned by institutional investors and hedge funds. </p>
<form method="get" action="https://www.marketbeat.com/newsletter/default.aspx" style="border-bottom-width: 1px; border-color: #D2D2D2; border-style: solid; border-top-width: 1px; margin-bottom: 24px; margin-top: 12px; padding: 12px 0;border-right:none;border-left:none;clear:both;">
    <input type="hidden" id="Hidden1" name="RegistrationCode" value="InPost-WKRB News"  />
    <input type="hidden" id="Hidden2" name="RegisterTicker" value="NYSE:MKC" />    <label for="InPostRegistrationEmail">Get <b>McCormick & Company Incorporated</b> alerts:</label>
    <div style="display:inline-block;"><input id="InPostRegistrationEmail" name="RegisterEmail" type="email" placeholder="Enter Your Email Address" style="border: 1px solid #D2D2D2;font-size: 0.9em;line-height: 1em;margin: 0;min-width: 200px; padding: 4px;" /><input type="submit" name="submit" class="button" onclick="return CheckEmail('InPostRegistrationEmail','ShowSuggestionInPost');" value="Submit" style="-webkit-appearance: none;-moz-appearance: none;appearance: none;font-size: 0.9em;font-weight: 700;line-height: 1em;padding: 6px 18px"></div>
</form>
<div id="ShowSuggestionInPost"></div>


<h2>McCormick &#038; Company, Incorporated Stock Up 0.8 %</h2>
<p>Shares of <a href='https://www.marketbeat.com/stocks/NYSE/MKC/sec-filings/' target='_blank' rel="noopener noreferrer">NYSE:MKC</a> opened at $79.14 on Monday. The company has a debt-to-equity ratio of 0.85, a current ratio of 0.74 and a quick ratio of 0.31. McCormick &#038; Company, Incorporated has a one year low of $77.67 and a one year high of $107.35. The company has a 50 day moving average of $85.58 and a 200-day moving average of $91.44. The stock has a market cap of $21.23 billion, a price-to-earnings ratio of 31.28, a P/E/G ratio of 5.60 and a beta of 0.51. </p>
<p>
		  <div class="in-article-ad" class="width:340px;">
<iframe src="https://marketbeat.com/scripts/336x280AdNewsSites.ashx" width="336" height="280" frameborder="no" title="Offer"></iframe>
</div>


                 McCormick &#038; Company, Incorporated (<a href='https://www.marketbeat.com/stocks/NYSE/MKC/'>NYSE:MKC</a> &#8211; <a style='font-weight:normal;text-decoration:italic;color:green' href='https://report.stocknews.com/sign-up/ticker/?ticker=MKC&#038;lead_source=marketbeat_snra&#038;utm_source=marketbeat_snra&#038;utm_medium=article&#038;utm_campaign=ticker&#038;utm_term=MKC&#038;utm_content=text_link'>Get Rating</a>) last released its quarterly earnings results on Wednesday, June 29th. The company reported $0.48 EPS for the quarter, missing the consensus estimate of $0.65 by ($0.17). McCormick &#038; Company, Incorporated had a net margin of 10.78% and a return on equity of 16.48%. The business had revenue of $1.54 billion during the quarter, compared to analyst estimates of $1.61 billion. During the same quarter last year, the company posted $0.69 earnings per share. The company&#8217;s revenue was down 1.3% on a year-over-year basis.  On average, sell-side analysts forecast that  McCormick &#038; Company, Incorporated will post 2.65 earnings per share for the current year. </p>
<h2>McCormick &#038; Company, Incorporated Dividend Announcement</h2>
<p>The company also recently announced a quarterly dividend, which was paid on Monday, July 25th. Shareholders of record on Monday, July 11th were given a dividend of $0.37 per share. This represents a $1.48 dividend on an annualized basis and a yield of 1.87%. The ex-dividend date of this dividend  was Friday, July 8th. McCormick &#038; Company, Incorporated&#8217;s dividend payout ratio  is presently 58.50%. </p>
<h2>Insiders Place Their Bets</h2>
<p>In other news, Director <a target='_blank' rel="noopener noreferrer" href='https://www.insidertrades.com/mccormick-company-incorporated-stock/margaret-m-v-preston/'>Margaret M. V. Preston</a> sold 10,580 shares of the company&#8217;s stock in a transaction on Wednesday, June 29th. The shares were sold at an average price of $84.44, for a total value of $893,375.20. Following the sale, the director now directly owns 12,660 shares of the company&#8217;s stock, valued at approximately $1,069,010.40. The transaction was disclosed in a legal filing with the SEC, which is available at <a href="https://www.sec.gov/Archives/edgar/data/63754/000106299322015715/xslF345X03/form4.xml" target='_blank' rel="noopener noreferrer">the SEC website</a>. Company insiders own  15.90% of the company&#8217;s stock. </p>
<h2>Analyst Upgrades and Downgrades</h2>
<p>MKC has been the topic of a number of research reports. Barclays dropped their price target on McCormick &#038; Company, Incorporated from $94.00 to $82.00 and set an &#8220;equal weight&#8221; rating on the stock in a research report on Monday, September 12th. TheStreet lowered shares of McCormick &#038; Company, Incorporated from a &#8220;b&#8221; rating to a &#8220;c+&#8221; rating in a research note on Wednesday, June 15th. Argus lowered shares of McCormick &#038; Company, Incorporated from a &#8220;buy&#8221; rating to a &#8220;hold&#8221; rating in a research note on Wednesday, July 6th. Finally, Deutsche Bank Aktiengesellschaft decreased their target price on shares of McCormick &#038; Company, Incorporated from $85.00 to $79.00 and set a &#8220;hold&#8221; rating for the company in a research report on Thursday, September 8th. Five analysts have rated the stock with a hold rating,  According to data from MarketBeat.com, McCormick &#038; Company, Incorporated presently has an average rating of &#8220;Hold&#8221; and a consensus target price of $93.25.</p>
<h2 style='display:inline-block'>McCormick &#038; Company, Incorporated Profile</h2>
<p> (<a style='font-weight:normal;text-decoration:italic;color:green' href='https://report.stocknews.com/sign-up/ticker/?ticker=MKC&#038;lead_source=marketbeat_snra&#038;utm_source=marketbeat_snra&#038;utm_medium=article&#038;utm_campaign=ticker&#038;utm_term=MKC&#038;utm_content=text_link'>Get Rating</a>)</p>
<p>McCormick &amp; Company, Incorporated manufactures, markets, and distributes spices, seasoning mixes, condiments, and other flavorful products to the food industry. It operates in two segments, Consumer and Flavor Solutions. The Consumer segment offers spices, herbs, and seasonings, as well as condiments and sauces, and desserts.</p>
<h2>Featured Articles</h2>
<ul>
<li><a href='https://report.stocknews.com/sign-up/ticker/?ticker=MKC&#038;lead_source=marketbeat_snra&#038;utm_source=marketbeat_snra&#038;utm_medium=article&#038;utm_campaign=ticker&#038;utm_term=MKC&#038;utm_content=text_link' target='_blank' rel="noopener noreferrer">Get a free copy of the StockNews.com research report on McCormick &#038; Company, Incorporated (MKC)</a></li>
<li><a href='https://www.marketbeat.com/originals/upwork-shares-stumble-into-bargain-territory/' target='_blank' rel="noopener noreferrer">Upwork Shares Stumble into Bargain Territory </a></li>
<li><a href='https://www.marketbeat.com/originals/krogers-is-your-one-stop-consumer-staples-stock/' target='_blank' rel="noopener noreferrer">Kroger’s is Your One-Stop Consumer Staples Stock</a></li>
<li><a href='https://www.marketbeat.com/originals/adobe-perfects-the-art-of-the-faceplant-for-investors/' target='_blank' rel="noopener noreferrer">Adobe Perfects the Art of the Faceplant for Investors</a></li>
<li><a href='https://www.marketbeat.com/originals/tax-credits-are-the-incentives-in-the-inflation-reduction-act/' target='_blank' rel="noopener noreferrer">Tax Credits are the Incentives in the Inflation Reduction Act </a></li>
<li><a href='https://www.marketbeat.com/originals/stock-market-3-islands-of-strength-in-a-sea-of-red/' target='_blank' rel="noopener noreferrer">Stock Market: 3 Islands Of Strength In A Sea Of Red</a></li>
</ul>
<p><!--ViewCount:ArticleHistoryID=95390274&PostDate=2022-9-19&type=f&id=12896785--></p>
<p><strong>Want to see what other hedge funds are holding MKC?</strong> <a href="https://www.holdingschannel.com/hedge-funds/holding-mkc/">Visit HoldingsChannel.com</a> to get the latest 13F filings and insider trades for McCormick &#038; Company, Incorporated (<a href="https://www.marketbeat.com/stocks/NYSE/MKC/">NYSE:MKC</a> &#8211; <a style="font-weight:normal;text-decoration:italic;color:green" href="https://report.stocknews.com/sign-up/ticker/?ticker=MKC&#038;lead_source=marketbeat_snra&#038;utm_source=marketbeat_snra&#038;utm_medium=article&#038;utm_campaign=ticker&#038;utm_term=MKC&#038;utm_content=text_link">Get Rating</a>).</p>
<p style="text-align:center"><img loading="lazy" src="https://www.marketbeat.com/scripts/SECFilingChart.ashx?Prefix=NYSE&#038;Symbol=MKC" alt="Institutional Ownership by Quarter for McCormick &#038; Company, Incorporated (NYSE:MKC)" width="650" height="350"/></p>
<p><!--Keyword: McCormick & Company Incorporated,NYSE:MKC,MKC,Consumer Staple,57978020,SEC Filings,13F,Hedge Fund Holdings,Institutional Investor Holdings--><!--Ratings:3,4,NYSE:MKC--></p>

			 	<!-- end inline unit -->
				<!-- end main text -->
				<!-- Invalidate Article -->
					 
				<!-- End Invalidate -->

<!--Begin Footer Opt-In-->
<p style="clear:both"><strong>Receive News &amp; Ratings for McCormick & Company Incorporated Daily</strong> - Enter your email address below to receive a concise daily summary of the latest news and analysts' ratings for McCormick & Company Incorporated and related companies with <a href="/daily-email-updates-basic/?symbol=NYSE:MKC&c=McCormick+%26+Company+Incorporated" rel="nofollow" style="text-decoration:underline;font-weight:bold">MarketBeat.com's FREE daily email newsletter</a>.</p>
<form method="get" action="https://www.marketbeat.com/newsletter/default.aspx">
<input id="BelowPostRegistrationEmail" name="RegisterEmail" type="email" placeholder="Your Email Address" aria-label="Your Email Address" class="signup" />
<input type="hidden" id="Hidden3" name="RegistrationCode" value="WKRB News-Footer" />
<input type="hidden" id="Hidden4" name="RegisterTicker" value="NYSE:MKC" /><input class="button" type="submit" name="submit" onclick="return CheckEmail('BelowPostRegistrationEmail','ShowSuggestionFooter');" value="Sign-Up Now (Free)">
</form>
<div id="ShowSuggestionFooter"></div>
<!-- End Footer Opt-In -->

				</div> <!-- end: entry -->
				<!--/sse-->
				 				<!-- start article metadata -->
				 <div itemscope itemprop="image" itemtype="https://schema.org/ImageObject" style='display:none'>
 					<link itemprop="url" href="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?w=500&h=300&zc=2&src=https://www.marketbeat.com/logos/mccormick-amp;-company-incorporated-logo.jpg" />
 					<meta itemprop="width" content="500">
 					<meta itemprop="height" content="300">
				 </div>
				<div itemscope itemprop="publisher" itemtype="https://schema.org/Organization" style="display:none">
 					<div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
					 	<meta itemprop="url" content="https://www.wkrb13.com/wp-content/uploads/2021/05/wkrb-logo-01.png">
						  						 <meta itemprop="width" content="844">
						 <meta itemprop="height" content="336">
					 </div>
					<meta itemprop="name" content="WKRB News"/>
					<meta itemprop="url" content="https://wkrb13.com" />
 				</div>
				<!-- end article metadata -->
			</article>


<!-- More on MarketBeat -->
<iframe width="100%" height="600" scrolling="no" frameborder="no" src="https://www.marketbeat.com/scripts/MoreOnMarketBeatBelowPost.aspx" title="More Headlines"></iframe>
<!-- More on MarketBeat -->

<!--  below post unit position -->
		

			<nav id="prevnext"><!-- previous and next article links -->
				<a href="https://www.wkrb13.com/2022/09/19/elmwood-wealth-management-inc-acquires-1850-shares-of-global-x-renewable-energy-producers-etf-nysearcarnrg.html" rel="prev"><div class="previous"><h2 class="h4">&laquo; PREVIOUS HEADLINE</h2><p>Elmwood Wealth Management Inc. Acquires 1,850 Shares of Global X Renewable Energy Producers ETF (NYSEARCA:RNRG)</p></div></a>				<a href="https://www.wkrb13.com/2022/09/19/archford-capital-strategies-llc-purchases-977-shares-of-amerisourcebergen-co-nyseabc.html" rel="next"><div class="next"><h2 class="h4">NEXT HEADLINE &raquo;</h2><p>Archford Capital Strategies LLC Purchases 977 Shares of AmerisourceBergen Co. (NYSE:ABC)</p></div></a>			
			</nav><!-- end previous and next article links -->
			
		
		<div id="latest-news">
				
				<h2>You might be interested in:</h2>
			 				 <div class="latest-news-item">
												<div class="item-image-bar"><div class="item-image-wrapper"><img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/textron-inc-logo.jpg&amp;h=45&amp;w=95&amp;zc=2" width="65" height="31" alt="Kwmg LLC Acquires 1,536 Shares of Textron Inc. " />
						</div></div>
				 <!--end: longthumb-->
						<a href="https://www.wkrb13.com/2022/09/19/kwmg-llc-acquires-1536-shares-of-textron-inc-nysetxt.html" rel="bookmark">Kwmg LLC Acquires 1,536 Shares of Textron Inc. </a>
				</div>
	 							 <div class="latest-news-item">
												<div class="item-image-bar"><div class="item-image-wrapper"><img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/ishares-sp-500-value-etf-logo.png?v=20210809124122&amp;h=45&amp;w=95&amp;zc=2" width="65" height="31" alt="Kwmg LLC Increases Position in iShares S&#038;P 500 Value ETF " />
						</div></div>
				 <!--end: longthumb-->
						<a href="https://www.wkrb13.com/2022/09/19/kwmg-llc-increases-position-in-ishares-sp-500-value-etf-nysearcaive.html" rel="bookmark">Kwmg LLC Increases Position in iShares S&#038;P 500 Value ETF </a>
				</div>
	 							 <div class="latest-news-item">
												<div class="item-image-bar"><div class="item-image-wrapper"><img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/corteva-inc-logo.png&amp;h=45&amp;w=95&amp;zc=2" width="65" height="31" alt="Sugarloaf Wealth Management LLC Has $67,000 Stock Position in Corteva, Inc. " />
						</div></div>
				 <!--end: longthumb-->
						<a href="https://www.wkrb13.com/2022/09/19/sugarloaf-wealth-management-llc-has-67000-stock-position-in-corteva-inc-nysectva.html" rel="bookmark">Sugarloaf Wealth Management LLC Has $67,000 Stock Position in Corteva, Inc. </a>
				</div>
	 							 <div class="latest-news-item">
												<div class="item-image-bar"><div class="item-image-wrapper"><img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/whirlpool-corporatio-logo.jpg&amp;h=45&amp;w=95&amp;zc=2" width="65" height="31" alt="Whirlpool  Hits New 1-Year Low at $143.41" />
						</div></div>
				 <!--end: longthumb-->
						<a href="https://www.wkrb13.com/2022/09/19/whirlpool-nysewhr-hits-new-1-year-low-at-143-41.html" rel="bookmark">Whirlpool  Hits New 1-Year Low at $143.41</a>
				</div>
	 							 <div class="latest-news-item">
												<div class="item-image-bar"><div class="item-image-wrapper"><img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/spdr-bloomberg-barclays-convertible-securities-etf-logo.jpg?v=20210722100749&amp;h=45&amp;w=95&amp;zc=2" width="65" height="31" alt="Archford Capital Strategies LLC Purchases 1,139 Shares of SPDR Bloomberg Convertible Securities ETF " />
						</div></div>
				 <!--end: longthumb-->
						<a href="https://www.wkrb13.com/2022/09/19/archford-capital-strategies-llc-purchases-1139-shares-of-spdr-bloomberg-convertible-securities-etf-nysearcacwb.html" rel="bookmark">Archford Capital Strategies LLC Purchases 1,139 Shares of SPDR Bloomberg Convertible Securities ETF </a>
				</div>
	 							 <div class="latest-news-item">
												<div class="item-image-bar"><div class="item-image-wrapper"><img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/vanguard-total-world-stock-etf-logo.png?v=20210827104610&amp;h=45&amp;w=95&amp;zc=2" width="65" height="31" alt="Vanguard Total World Stock ETF  Shares Sold by Archford Capital Strategies LLC" />
						</div></div>
				 <!--end: longthumb-->
						<a href="https://www.wkrb13.com/2022/09/19/vanguard-total-world-stock-etf-nysearcavt-shares-sold-by-archford-capital-strategies-llc.html" rel="bookmark">Vanguard Total World Stock ETF  Shares Sold by Archford Capital Strategies LLC</a>
				</div>
	 						</div><!-- end latest news -->

<!-- second ad spot -->

<br>
	</main> <!-- end main -->
<aside class="flex-sidebar">
<div class="flex-container">	
<div class="sidebar-section">
	
<iframe src="https://marketbeat.com/scripts/MoreOnMarketBeat.aspx" width="336" height="600" frameborder="no" title="More Articles"></iframe><br><br>
	
<!-- Network Wide AdSense Unit - Top Sidebar Position -->
<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-9373162611283935" data-ad-slot="1875628183" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>(adsbygoogle = window.adsbygoogle || []).push({});</script>
<!-- End AdSense Unit -->
<br><br>
<!-- end first square unit -->

<!-- Network Wide AdSense Unit - Middle Sidebar Position -->
<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-9373162611283935" data-ad-slot="9445683366" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>(adsbygoogle = window.adsbygoogle || []).push({});</script>
<!-- End AdSense Unit -->
<br><br>	
<!-- end second square unit -->
		
</div>	
<div class="sidebar-section">
<!-- OptIn Form -->

<!-- Start Sidebar Registration -->
<div class="sidebar-email">
                        <h3>Daily Ratings &amp; News for McCormick & Company Incorporated</h3>
        	Complete the form below to receive the latest headlines and analysts' recommendations for McCormick & Company Incorporated with our free daily email newsletter:<br/>
        <form method="get" action="https://www.marketbeat.com/newsletter/default.aspx">
        <input id="RegisterEmailSidebar" style='width:100%' name="RegisterEmail" type="email" placeholder="Your Email Address" aria-label="Your Email Address">
        <input type="hidden" id="Hidden7" name="RegistrationCode" value="WKRB News-Sidebar">
        <input type="hidden" id="Hidden8" name="RegisterTicker" value="NYSE:MKC" />        <input type="submit" name="submit" onclick="return CheckEmail('RegisterEmailSidebar', 'ShowSuggestionSidebar');" value="Subscribe Now (Free Sign-Up)" class="button" style="width:100%;height:30px">
    <div id="ShowSuggestionSidebar" style="padding-top:7px"></div>
    </form>
    </div>

<!-- End Sidebar Registration -->
	
<!-- optional social media -->
	
 
		<br>
	
	<a style="background: #075A8D;color: #fff;padding: 5px 7px 4px;border-radius: 3px;font-size: 12px;text-decoration: none;" href="https://twitter.com/intent/follow?original_referer=https%3A%2F%2Fwww.wkrb13.com%2F&ref_src=twsrc%5Etfw&screen_name=WKRBnews" target="_blank" rel="noopener nofollow">
<svg style="width: 13px;vertical-align: middle;margin-right: 4px;fill: #fff;" xmlns="http://www.w3.org/2000/svg" width="24" height="24" viewBox="0 0 24 24"><path d="M24 4.557c-.883.392-1.832.656-2.828.775 1.017-.609 1.798-1.574 2.165-2.724-.951.564-2.005.974-3.127 1.195-.897-.957-2.178-1.555-3.594-1.555-3.179 0-5.515 2.966-4.797 6.045-4.091-.205-7.719-2.165-10.148-5.144-1.29 2.213-.669 5.108 1.523 6.574-.806-.026-1.566-.247-2.229-.616-.054 2.281 1.581 4.415 3.949 4.89-.693.188-1.452.232-2.224.084.626 1.956 2.444 3.379 4.6 3.419-2.07 1.623-4.678 2.348-7.29 2.04 2.179 1.397 4.768 2.212 7.548 2.212 9.142 0 14.307-7.721 13.995-14.646.962-.695 1.797-1.562 2.457-2.549z"/></svg> Follow @WKRBnews</a>
		
	
<!-- end optional social media -->

<!-- sidebar unit position -->


<!-- start Recent Posts -->
        <br/>
        <div>
        <h3>Recent News</h3>
            <ul>
                        <li class="recent-posts"><a href="https://www.wkrb13.com/2022/09/19/kwmg-llc-acquires-1536-shares-of-textron-inc-nysetxt.html">Kwmg LLC Acquires 1,536 Shares of Textron Inc. (NYSE:TXT)</a></li>
                        <li class="recent-posts"><a href="https://www.wkrb13.com/2022/09/19/kwmg-llc-increases-position-in-ishares-sp-500-value-etf-nysearcaive.html">Kwmg LLC Increases Position in iShares S&#038;P 500 Value ETF (NYSEARCA:IVE)</a></li>
                        <li class="recent-posts"><a href="https://www.wkrb13.com/2022/09/19/sugarloaf-wealth-management-llc-has-67000-stock-position-in-corteva-inc-nysectva.html">Sugarloaf Wealth Management LLC Has $67,000 Stock Position in Corteva, Inc. (NYSE:CTVA)</a></li>
                        <li class="recent-posts"><a href="https://www.wkrb13.com/2022/09/19/whirlpool-nysewhr-hits-new-1-year-low-at-143-41.html">Whirlpool (NYSE:WHR) Hits New 1-Year Low at $143.41</a></li>
                        <li class="recent-posts"><a href="https://www.wkrb13.com/2022/09/19/archford-capital-strategies-llc-purchases-1139-shares-of-spdr-bloomberg-convertible-securities-etf-nysearcacwb.html">Archford Capital Strategies LLC Purchases 1,139 Shares of SPDR Bloomberg Convertible Securities ETF (NYSEARCA:CWB)</a></li>
                        <li class="recent-posts"><a href="https://www.wkrb13.com/2022/09/19/vanguard-total-world-stock-etf-nysearcavt-shares-sold-by-archford-capital-strategies-llc.html">Vanguard Total World Stock ETF (NYSEARCA:VT) Shares Sold by Archford Capital Strategies LLC</a></li>
                        <li class="recent-posts"><a href="https://www.wkrb13.com/2022/09/19/archford-capital-strategies-llc-purchases-977-shares-of-amerisourcebergen-co-nyseabc.html">Archford Capital Strategies LLC Purchases 977 Shares of AmerisourceBergen Co. (NYSE:ABC)</a></li>
                        <li class="recent-posts"><a href="https://www.wkrb13.com/2022/09/19/elmwood-wealth-management-inc-sells-808-shares-of-mccormick-company-incorporated-nysemkc.html">Elmwood Wealth Management Inc. Sells 808 Shares of McCormick &#038; Company, Incorporated (NYSE:MKC)</a></li>
                        <li class="recent-posts"><a href="https://www.wkrb13.com/2022/09/19/elmwood-wealth-management-inc-acquires-1850-shares-of-global-x-renewable-energy-producers-etf-nysearcarnrg.html">Elmwood Wealth Management Inc. Acquires 1,850 Shares of Global X Renewable Energy Producers ETF (NYSEARCA:RNRG)</a></li>
                        <li class="recent-posts"><a href="https://www.wkrb13.com/2022/09/19/lightstreams-pht-price-hits-0-0025-on-top-exchanges.html">Lightstreams (PHT) Price Hits $0.0025 on Top Exchanges</a></li>
                        <li class="recent-posts"><a href="https://www.wkrb13.com/2022/09/19/gems-one-day-trading-volume-reaches-51777-00-gem.html">Gems  One Day Trading Volume Reaches $51,777.00 (GEM)</a></li>
                        <li class="recent-posts"><a href="https://www.wkrb13.com/2022/09/19/sentinel-chain-market-capitalization-tops-77260-92-senc.html">Sentinel Chain Market Capitalization Tops $77,260.92 (SENC)</a></li>
                        <li class="recent-posts"><a href="https://www.wkrb13.com/2022/09/19/bitcoin-2-btc2-trading-7-2-lower-over-last-week.html">Bitcoin 2 (BTC2)  Trading 7.2% Lower  Over Last Week</a></li>
                        <li class="recent-posts"><a href="https://www.wkrb13.com/2022/09/19/solfarm-24-hour-trading-volume-tops-497729-00-tulip.html">SolFarm 24 Hour Trading Volume Tops $497,729.00 (TULIP)</a></li>
                        <li class="recent-posts"><a href="https://www.wkrb13.com/2022/09/19/penta-price-hits-0-0000-pnt.html">Penta Price Hits $0.0000  (PNT)</a></li>
                        <li class="recent-posts"><a href="https://www.wkrb13.com/2022/09/19/ally-reaches-market-cap-of-1-44-million-aly.html">ALLY Reaches Market Cap of $1.44 Million (ALY)</a></li>
                        <li class="recent-posts"><a href="https://www.wkrb13.com/2022/09/19/elmwood-wealth-management-inc-increases-stake-in-ishares-treasury-floating-rate-bond-etf-nysearcatflo.html">Elmwood Wealth Management Inc. Increases Stake in iShares Treasury Floating Rate Bond ETF (NYSEARCA:TFLO)</a></li>
                        <li class="recent-posts"><a href="https://www.wkrb13.com/2022/09/19/vanguard-extended-market-etf-nysearcavxf-shares-sold-by-minot-wealth-management-llc.html">Vanguard Extended Market ETF (NYSEARCA:VXF) Shares Sold by Minot Wealth Management LLC</a></li>
                        <li class="recent-posts"><a href="https://www.wkrb13.com/2022/09/19/archford-capital-strategies-llc-acquires-972-shares-of-ishares-ibonds-dec-2028-term-corporate-etf-nysearcaibdt.html">Archford Capital Strategies LLC Acquires 972 Shares of iShares iBonds Dec 2028 Term Corporate ETF (NYSEARCA:IBDT)</a></li>
                        <li class="recent-posts"><a href="https://www.wkrb13.com/2022/09/19/sugarloaf-wealth-management-llc-grows-stock-position-in-ishares-1-3-year-treasury-bond-etf-nasdaqshy.html">Sugarloaf Wealth Management LLC Grows Stock Position in iShares 1-3 Year Treasury Bond ETF (NASDAQ:SHY)</a></li>
                        </ul>
        </div>  
</div>
</div>
<!-- end recent posts -->
</aside><!--end #sidebar-->
	<div style="clear: both;"></div>
</div> <!-- end .width-limiter -->
<footer class="full-width">
	<div class="width-limiter flex-container">
		<div id="footer-info" class="add-padding flex-nav">
			<nav class="navigation" aria-label="Category Links"><ul id="menu-category-menu-2" class="menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-31"><a href="https://www.wkrb13.com/category/markets">Markets</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-60"><a href="https://www.wkrb13.com/category/markets/analyst-articles-us">Ratings</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-54"><a href="https://www.wkrb13.com/category/markets/dividend-articles">Dividends</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-55"><a href="https://www.wkrb13.com/category/markets/earnings-articles-single">Earnings</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56"><a href="https://www.wkrb13.com/category/markets/insider-trades">Insider Trades</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24"><a href="https://www.wkrb13.com/category/markets/cryptocurrencies">Cryptocurrencies</a></li>
</ul></nav>		</div><!-- end #footer-info -->
		<span id="copyright" class="add-padding flex-copyright">
				&copy; 2018-2022 <a href="https://www.wkrb13.com">WKRB News</a>
	    </span>
	</div>	
	<!-- Begin Internal Tracking Pixel 2 -->
		<script type='text/javascript'>document.write('<img src="https://www.american' + 'consumernews.net/scripts/standalone/viewcount.ashx?ArticleHistoryID=95391112&PostDate=2022-9-19&type=f&id=12897128&domain=www.wkrb13.com&referrer=' + encodeURIComponent(document.referrer) + '" alt="" width="1" height="1" style="float:left;" />');</script>
		<!-- End Internal Tracking Pixel 2-->
</footer>
		<script type='text/javascript' src='https://www.wkrb13.com/wp-includes/js/wp-embed.min.js?ver=5.5.10' id='wp-embed-js'></script>
</div>
<!-- MarketBeat News Network StatCounter Code -->
<script type="text/javascript">var sc_project=9021069; var sc_invisible=1; var sc_security="fdde5482"; var sc_https=1; </script>
<script type="text/javascript" src="https://www.statcounter.com/counter/counter.js"></script>
<noscript><img class="statcounter" src="https://c.statcounter.com/9021069/0/fdde5482/1/" height="1" width="1" alt=""></noscript>
<!-- End MarketBeat News Network StatCounter Code -->

<!-- Start of Site Specific StatCounter Code -->
<script type="text/javascript">
var sc_project=11650630; 
var sc_invisible=1; 
var sc_security="2798fb99"; 
</script>
<script type="text/javascript" src="https://www.statcounter.com/counter/counter.js"></script>
<noscript><img class="statcounter" src="https://c.statcounter.com/11650630/0/2798fb99/1/" height="1" width="1"  alt=""></noscript>
<!-- End of Site Specific StatCounter Code -->

	</body>
</html>
